Last Comment Bug 832396 - Windows desktop emulators of B2G start only until 'powered by' marble screen shown
: Windows desktop emulators of B2G start only until 'powered by' marble screen ...
Status: RESOLVED WORKSFORME
: l12y
Product: Firefox OS
Classification: Client Software
Component: GonkIntegration (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 832469 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 10:29 PST by Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
Modified: 2013-10-22 02:47 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-01-18 10:29:36 PST
Windows XP SP3 32 bit

The Windows desktop emulators of B2G start only until the 'powered by' marble screen is shown.

1. I downloaded the latest b2g-beta Windows desktop emulator build, should be https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2013-01-18-07-02-01-mozilla-b2g18/b2g-18.0.multi.win32-localizer.zip (I downloaded it from the latest-mozilla-b2g folder).

2. Launch the build.

Actual result:
The emulator stops at the "powered by" text and marble picture.
Comment 1 KM Lee [:rexboy] 2013-01-31 19:10:00 PST
Reproduced on Windows 8.
I compiled the desktop build by myself and got the same result.
Comment 2 blacharnia 2013-07-14 03:02:45 PDT
the same for b2g-25.0a1.multi.win32 on Win7 x64. Anyone else ;-)?
Comment 3 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-07-14 10:57:16 PDT
You have to download the Windows and the Linux build, unpack the Windows one except the 'gaia' folder and extract the 'gaia' folder from the Linux build into the same parent directory like the Windows one to get a working, localized emulator. These steps work for B2G18, I don't know about Nightly versions.
Comment 4 blacharnia 2013-07-15 12:09:13 PDT
these indeed worked for the nightly as well, thanks. But now, I cannot get the screen to slide up and see the home screen. The screen goes slightly up and goes back down. Any ideas?
Comment 5 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-07-15 12:34:02 PDT
Left-click and hold at the bottom, then drag upwards to see the buttons.
Comment 6 blacharnia 2013-07-15 12:55:52 PDT
Nope, does not go up. The same on Ubuntu with the whole original package. Only solution I found so far is to disable the lock screen on the first time usage and keep it like that.
Comment 7 Dave Hunt (:davehunt) 2013-07-15 14:09:09 PDT
(In reply to blacharnia from comment #4)
> these indeed worked for the nightly as well, thanks. But now, I cannot get
> the screen to slide up and see the home screen. The screen goes slightly up
> and goes back down. Any ideas?

That's logged as bug 891882.
Comment 8 blacharnia 2013-07-15 14:14:10 PDT
(In reply to Dave Hunt (:davehunt) from comment #7)
> (In reply to blacharnia from comment #4)
> > these indeed worked for the nightly as well, thanks. But now, I cannot get
> > the screen to slide up and see the home screen. The screen goes slightly up
> > and goes back down. Any ideas?
> 
> That's logged as bug 891882.

Ok, thnx for the info.
Comment 9 John Ford [:jhford] CET/CEST Berlin Time 2013-08-08 14:45:52 PDT
*** Bug 832469 has been marked as a duplicate of this bug. ***
Comment 10 Florin Strugariu [:Bebe] 2013-10-21 07:09:20 PDT
I tested this on Windows 7 x64  and the emulator starts as expected.

Downloaded the build from:
http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/
Comment 11 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-10-22 02:47:14 PDT
Also works for me with the builds from mozilla-central.

Note You need to log in before you can comment on or make changes to this bug.