If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Auto-identification of mobile phone on cell network is not working (Bango)

RESOLVED FIXED in 2013-02-07

Status

Marketplace
Payments/Refunds
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kumar, Assigned: Keir Kettle)

Tracking

2013-02-07
x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Whiteboard: [blocked on telefonica] u=patron p=1)

STR
- Set up a phone for use with the development payment servers per https://github.com/mozilla/webpay#setting-up-a-b2g-device
- Turn off wifi and make sure your SIM is active on a data connection
- Go to the dev Marketplace. You may need to install it from http://people.mozilla.com/~kmcmillan/mktdev.html
- Search for the Private Yacht
- Purchase the app and create/enter your PIN

Expected: you should immediately see the cancel/buy screen because the phone should be identified over the cell network headers

Actual: you are prompted to send an SMS to identify your phone.
Keir, is this something that the test server is expected to support? Or do we need to try this in Bango's production env? Also, we are using Telefonica SIMs but we are roaming here in the US on AT&T.
Assignee: nobody → sruston
Priority: -- → P1
Target Milestone: --- → 2013-01-24
Blocks: 775802
Whiteboard: u=patron p=
(Assignee)

Comment 2

5 years ago
I don't think the identification integration with BlueVia is working yet.  I will get a status update and update
Steve says this will be fixed tomorrow

Comment 4

5 years ago
Bango and BV have both now pushed their code to production although we are waiting on the certificates to be deployed at BV which will happen on the 29th. I am trying to clarify whether that will impact this

Comment 5

5 years ago
Keir, please notify Kumar when the certificates are done and this is resolved
Assignee: sruston → keir
Version: 1.0 → 1.1
Whiteboard: u=patron p= → [blocked on telefonica] u=patron p=1
Target Milestone: 2013-01-24 → 2013-02-07
(Assignee)

Comment 6

5 years ago
This is now available (when using the live platform). I can't mark resolved fixed - there is no fixed option in the second drop down.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Depends on: 840772
You need to log in before you can comment on or make changes to this bug.