Last Comment Bug 832414 - Since upgrading to Firefox 18, icloud.com doesn't recognize user actions
: Since upgrading to Firefox 18, icloud.com doesn't recognize user actions
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 18 Branch
: x86_64 Windows 8
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 11:07 PST by telvaus
Modified: 2013-01-27 13:59 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description telvaus 2013-01-18 11:07:41 PST
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

1. Signed on to icloud.com
2. Clicked calendar icon
3. Calendar page loaded.
4. Attempted to add a calendar item
5. Exited Firefox, signed into iCloud again, went to Reminders Page, attempted to add a reminder


Actual results:

No problem loading icloud.com home page
Once a link was clicked (e.g., Calendar, Reminders), that page loaded and then the window froze. No further interaction was accepted, requiring an exit from Firefox.


Expected results:

User input should have been accepted, e.g., a new calendar input screen should have loaded, a new Reminder screen should have loaded, or an edit screen should have loaded. No problems had been experienced with Firefox 17. Also, attempted same actions using IE10 and experienced no problem. Am using Windows 8, fully updated.
Comment 1 the-edmeister 2013-01-18 11:52:43 PST
Related SUMO support thread is here: https://support.mozilla.org/en-US/questions/946870
Comment 2 Matthias Versen [:Matti] 2013-01-18 21:00:31 PST
works for me with : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

I have never used the page but here is what i have done:
1) loaded http://icloud.com
2) logged in with my Apple-ID
3) clicked the calendar icon
4) double clicked at on the calendar
5) a "popup" appeared where i could create a calendar entry
6) added "test" and hit ok
7) the calendar entry got saved

Please try it without addons, on windows help/restart with addons disabled
Comment 3 telvaus 2013-01-20 03:48:02 PST
I followed the procedure you outlined above exactly and user input froze when I executed step #4. This is exactly what happened when I tried previously. 

Before trying your procedure, I disabled all Firefox Extensions and Plugins, restarted Firefox and confirmed that all Extensions and Plugins had been disabled.
Comment 4 Matthias Versen [:Matti] 2013-01-20 16:12:52 PST
>I disabled all Firefox Extensions and Plugins, restarted Firefox and confirmed that all Extensions and Plugins had been disabled.

Do you manually disabled them or do you used the safemode (help/restart with addons disabled) ?
The Firefox safemode does more than only disabling extension....
Comment 5 telvaus 2013-01-21 06:53:25 PST
Yes, I manually disabled add-ons and extensions. However, I just now tried the Help/Restart in Safe Mode and the result was exactly the same.
Comment 6 Matthias Versen [:Matti] 2013-01-21 16:43:34 PST
Can you please try it with a new profile ?
- http://support.mozilla.org/kb/Managing%20profiles
Comment 7 telvaus 2013-01-22 05:38:39 PST
Set up new profile. Same result.

Opened new profile in safe mode and tried again. Also same result.

Deleted new profile and returned to old profile.
Comment 8 Matthias Versen [:Matti] 2013-01-22 23:06:30 PST
I have no idea why it doesn't work for you while it works for me on my system....
Comment 9 Clay Law 2013-01-25 17:41:03 PST
Please check the support forum for detail info on this bug - it does seem to have been resolved in the latest Firefox 19 Beta 3. This problem occurs from 18-19 Beta 2. It also occurs on more than just Windows 8 systems.

https://support.mozilla.org/en-US/questions/946870
Comment 10 telvaus 2013-01-26 06:51:19 PST
I just tried iCloud and it now works for me also. The strange thing is that nothing, zero, nada has changed with my setup. In fact, I'm still on the same version of Firefox, Version 18.0. Is it possible that Apple made a change on their site that fixed the problem?
Comment 11 Matthias Versen [:Matti] 2013-01-27 13:59:07 PST
It's possible that they changed something.
I will mark this report wfm since it works for you and Clay reports that it's fixed in 19b3

Note You need to log in before you can comment on or make changes to this bug.