If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Support Roles in MailNews

VERIFIED DUPLICATE of bug 36482

Status

MailNews Core
Composition
--
enhancement
VERIFIED DUPLICATE of bug 36482
17 years ago
9 years ago

People

(Reporter: Kousik Nandy, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
It'll be really exciting if it is possible to support Roles like PINE.

Comment 1

17 years ago
reporter,
Can you please explain?
(Reporter)

Comment 2

17 years ago
You may play different roles with the same mail account. Say you're a help
desk worker, and helpme@example.com is aliased to myself@example.com. When
you're replying to a message addressed to helpme it'll require you to use a
different return address and/or a different signature. Also you may want to
file a copy of the message somewhere else instead of usual sent. All these
to be done automatically.

Each role will have a `pattern', and corresponding `action'. So when you
reply a message, the message is matched with the role patterns, if a match
is found, corresponding actions are taken.

'Patterns' might be same as we have in filters, we may specify if "To" is
such, set "From", "Reply-To" and signature to so & so as 'action' (or even
we can specify the template).
(Assignee)

Comment 3

17 years ago
Why not just setup several accounts/identities, each which different reply-to of
copy folder setting?
(Reporter)

Comment 4

17 years ago
Uh ... doesn't each account asks me for a incoming mail server address?
We may have only one of that; but want to play different roles. I thought
of that anyway, but seems like I can't have an identity without specifying
a mail server. Please correct me if I'm wrong and close the bug.
(Assignee)

Comment 5

17 years ago
Right, identity and account are tight together, at least in the UI. But why not
create two accounts using the same mail server but having just diferent setting
for the identity part of it.

Comment 6

17 years ago
change qa contact. sounds related to account manager.
QA Contact: sheelar → nbaca

Comment 7

17 years ago
kousik, as a workaround, you can create POP mail accounts with fake server names
and disable the autamatic mail check. You'll have lots of entires in teh folder
pane and shutdown might be slower, but you can select different Identities then.
I do that all the time here.

But this is no solution for this bug: The user still has to select the right
identitiy for each and every mail. In the helpdesk scenario, this is not
acceptable - too time consuming. Also, it is failure-prone  - lots of times, I
posted with my mail-only identity to newsgroups, opening them to spam :-(.

DUP of bug 36482.

*** This bug has been marked as a duplicate of 36482 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.