Thunderbird is non-responding all the time/ freezing up. Caused by AVG

RESOLVED INVALID

Status

Thunderbird
Untriaged
P1
critical
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: Mark Laney, Unassigned)

Tracking

({perf})

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [antivirus:AVG][antivirus:McAfee real time scanning])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

try to read my mail / send mail


Actual results:

cannot get into it consistently - always freeezing up and non-repsonding
out of 30 miutes, If I stayed at it, I might get 5-8 minutes of viewing done


Expected results:

It should not freezeup and become non-responsive
this is totally ridiculaous 
It is a thunderbird problem, I am guessing with the last update release because both my computers are doing the same thing
(Reporter)

Comment 1

5 years ago
turned off firewall no effect. 
Started TB in safe mode, the non responses time outs  are less frequent and of less duration, but are still there too often and too long. 
Frequently will get a message that asks if want to continue or cancel this script
while this non-responding script chrome://messenger/content/mailWindow.js:193
is seen the majority of the time
another non-responding script message is 
resource:///modules/gloda/log4moz.js:290
Severity: normal → critical
Priority: -- → P1

Comment 2

5 years ago
Can you see in tools->Activity manager whether Tb is doing something? Also, what is your exact TB version?
(Reporter)

Comment 3

5 years ago
yes it shows activity - e.g. no messages to download; one message downloaded; 
TB v. 17.0.2 - which says it is the latest.
(Reporter)

Comment 4

5 years ago
Solution found: apparently last update from McAfee Total Protection made a change such that  real time scanning causes TB 17.0.2 not to work correctly and was causing all the freezes and pauses.  Turning off real time scanning solved the TB issue.

Comment 5

5 years ago
You will probably want to finetune the antivirus to only exclude the TB profile (see in help->troubleshooting info for the path and the Local directory in each account's settings) and mail data files from realtime scanning, but otherwise leave the protection enabled for the rest of the system.

Comment 6

5 years ago
I do not have McAfee Total Protection.  I use AVG Free Edition 2013 and am experiencing the same type of freezing/non responsiveness after about 3 minutes of use.  Not sure how to finetune AVG.  Disabling it temporarilly seems to have resolved the problem, for now.  If someone can explain how to finetune it so I still have e-mail protection but to resolve the issue, that would be GREAT!

Jason

Comment 7

5 years ago
Jason, thanks for the info. It might be mentioned in https://wiki.mozilla.org/Thunderbird:Testing:Antivirus_Related_Performance_Issues  If the info is missing, please update the wiki
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: perf
Resolution: --- → INVALID
Summary: Thunderbird is non-responding all the time/ freezing up → Thunderbird is non-responding all the time/ freezing up. Caused by AVG
Whiteboard: [antivirus:AVG]

Updated

2 years ago
Whiteboard: [antivirus:AVG] → [antivirus:AVG][antivirus:McAfee real time scanning]
You need to log in before you can comment on or make changes to this bug.