Crash by refreshing News ("GetMsg")

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
--
critical
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: mg8, Assigned: Navin Gupta)

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I post some news into a group. Now, I click on the "GetMsg" button to refresh
the list and view my posting. In about three cases of four, Mozilla crashes
after clicking on GetMsg. I must restart it.

Updated

17 years ago
Keywords: crash

Updated

17 years ago
Component: Filters → Mail Window Front End
QA Contact: laurel → stephend
Component: Mail Window Front End → Networking - News
I'm not crashing with build 2001053004 on Windows 2000.  Reporter, can you
please note in the bug which build ID you are using, what news server/group you
are using, and if you are using a Talkback enabled build, what the ID of the
crashes are?  Thanks.
From Martin -

Thank you for testing. I used the original Mozilla 0.9 version, thus build
2001050515 on Windows98. I found the error when posting in
de.comm.infosystems.www.authoring.misc and click on GetMsg after the
posting. I don't know exactly if the bug only happens when clicking on
GetMsg directly after posting or also later.
And sorry, I had not enabled Talkback and am not sure if I even have
installed it. Hopefully, I can share more information on that by tomorrow.

Regards,
Martin
Martin, please try with a newer build from the /nightly directory, and see if
that clears up your problem.  Also, if you can, please make sure you get a
Talkback-enabled build so that we can get a stack trace and figure out where you
are crashing.  Thanks!
(Reporter)

Comment 4

17 years ago
Talkback from the original Mozilla 0.9 (build 2001050515) after a crash has 
been sent to you. The crash does at least appear when nobody else apart from 
you has posted into the group when clicking GetMsg.
Using the current nightly (build 2001053020), I could not reproduce any crash.
Created attachment 36713 [details]
TB31145448
I can't reproduce this today using build 2001-05-31-04 with Windows 2000.
I did:

Composed a posting to netscape.test on news.mozilla.org.  Sent the post.
Clicked GetMsg, found my message and clicked on it.
No crash.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Martin, is this still working for you?
Stephen:
I haven't tested the bug with newer nightly versions than the one of 30th
May. I will wait until 0.9.1.

Regards,  Martin


(Reporter)

Comment 9

17 years ago
This bug does not appear in Version 0.9.1. The problem seems to be solved.
worksforme, too.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.