Can't Save Screenshots w/ any of my Addons

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: afilbert, Unassigned)

Tracking

18 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130107224849

Steps to reproduce:

I use Awesome Screenshots addon to screengrab and annotate and crop images of web apps. I'm running various web product projects and this tool is invaluable. I have the most recent version of Firefox avail through Canonical installed (18) along with the most up-to-date Ubuntu 12 64bit version. About a week ago, after an update, all of my screengrab plugins stopped actually saving the file. I went through all the troubleshooting docs on the issue, including restarting, adding removing addons, resetting all the settings and mime-types, etc. After that all failed, I started firefox from my console and tried saving a cropped screengrab from Awesome Screenshot Plus (https://addons.mozilla.org/en-US/firefox/addon/awesome-screenshot-capture-/?src=ss).


Actual results:

The file save failed. The image never showed up in the folder that I tried to save it in. Here's the exception output from the console:

error: as-ff: An exception occurred.
Traceback (most recent call last):
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/timer.js", line 32, in notify
    callback.apply(null, args);
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/content/worker.js", line 108, in null
    self._emit.apply(self, JSON.parse(args));
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/events.js", line 123, in _emit
    return this._emitOnObject.apply(this, args);
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/events.js", line 153, in _emitOnObject
    listener.apply(targetObj, params);
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/content/worker.js", line 218, in postMessage
    self._addonWorker._emit('message', data);
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/events.js", line 123, in _emit
    return this._emitOnObject.apply(this, args);
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/events.js", line 153, in _emitOnObject
    listener.apply(targetObj, params);
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/as-ff/lib/main.js", line 49, in null
    ui.saveCanvas(message.data);
  File "resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/as-ff/lib/ui.js", line 77, in saveCanvas
    xfer.init(source, target, "", null, null, null, persist);
[Exception... "Not enough arguments [nsITransfer.init]"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: resource://gre/modules/XPIProvider.jsm -> jar:file:///home/aiden/.mozilla/firefox/g11o4ein.default-1341613685787/extensions/jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack.xpi!/bootstrap.js -> resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/api-utils/lib/loader.js -> resource://jid0-gxjllfbcoax0lcltedfrekqdqpi-at-jetpack/as-ff/lib/ui.js :: saveCanvas :: line 77"  data: no]


Expected results:

The screengrab image should have saved to the output directory and filename.
We don't track extensions bugs here and you have to ask the author of that extension for help.
There is a comment on the addon page with a link to a new version that seems to fix the issue according to the comment on the new version. Version 2.3.8 is also now marked as only compatible with Firefox17 and not 18.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 years ago
Thanks, Matthias. I simply used Awesome Screenshot as an example. I tried three different plugins that saved to my filesystem and they all failed. I assumed it was something to do, then, with the plugin infrastructure.
You need to log in before you can comment on or make changes to this bug.