moving cursor in textbox inserts duplicate of last word typed

RESOLVED INVALID

Status

()

Firefox for Android
Keyboards and IME
RESOLVED INVALID
5 years ago
a year ago

People

(Reporter: Owen Jones, Unassigned)

Tracking

18 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130115 Firefox/20.0
Build ID: 20130115042018

Steps to reproduce:

On my Galaxy Nexus running Android 4.2.1.

1. Go to www.google.com (but I think any page with a textbox would work).
2. Tap on the textbox on the page
3. Type some text in the textbox, e.g. "a big grou".
4. Note the most prominent suggestion in the line above the keyboard, e.g. "group". (To be clear, this is the suggestion from the keyboard, not from the google web site.)
4. Tap the screen to move the cursor anywhere in the text you've already entered.
5. Type another letter


Actual results:

If the letter you typed is a space or punctuation then the most prominent suggestion is inserted where the cursor is, followed by a space. e.g. "group " is inserted into "grou" to make "a big grgroup ou" (if you put your cursor after the second letter of "grou")

If the letter you type is not a space or punctuation then the last word is inserted followed by the letter you typed. E.g. if you type "x" in my example then you get "a big grgrouxou".



Expected results:

Only a letter you typed should be inserted. e.g. "a big gr ou" or "a big grxou"


Notes:
I don't have any apps related to the keyboard installed. I managed to stop the bug by fiddling with the Android keyboard settings by turning "show correction suggestions" to "Always hide". Interestingly, turning it to "Only show in portrait" made the bug manifest in portrait and landscape modes.

Also, the bug only happens the first time you tap to move the cursor. If you move it twice it doesn't happen. If you want to make it happen again you have to delete what's in the textbox, click out of it and then select it again.

I am happy to provide more help hunting down this bug because I really want to use Firefox for Android and this bug really annoys me.

Comment 1

5 years ago
Is this reproducing only in Firefox for Android or in other form inputs?
(Reporter)

Comment 2

5 years ago
I think just Firefox for Android, and I'm guessing not on many phones otherwise it would have been reported far earlier. (I forgot to mention, it has existed on the last few version of firefox before 18 as well.)
Can you try out Firefox Beta on Google Play and Aurora (http://aurora.mozilla.org) for Android and report back if things are working out for you?

Firefox 18 shipped before we introduced a number of IME and Keyboard related fixes. Newer versions of Firefox on Nightly/Aurora/Beta contain a number of fixes.

Let us know if either Firefox Beta or Aurora (or even Nightly (http://nightly.mozilla.org) work out for you.
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 4

5 years ago
Thanks for pointing me to that Aaron. The bug is fixed in nightly. For the record it is still present in Beta and I didn't try Aurora. I'll mark it as resolved then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.