If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't load XML file, no error, nothing...

VERIFIED WORKSFORME

Status

()

Core
XML
P2
normal
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: jst, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
mozilla0.9.9
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I get a crash in nsExpatTokenizer::PushXMLErrorTokens() when loading the above
URL (which is *not* public, so it *must* remain internal), the crash is due to
the scanner in mState being nsnull when we end up reporting an error. AFAIK from
looking at the file the file is well-formed, the error we're trying to report is
"no element found" at line 30, column 19.
(Reporter)

Comment 1

17 years ago
Nominating for mozilla0.9.2
Keywords: crash, mozilla0.9.2

Comment 2

17 years ago
Eh jst, I need to peep at that secret file of yours :-) Looks like the crash
is introduced by my patch for bug 47416. I am curious why the scanner is null
in the _tokenizer_...
Looks very similar to bug 82332.

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 82332 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
rbs, I'm sorry, but I can't move that file to a public place. I can tell you
tho, it's not empty :-) The crash is in the same place as the stack in bug 82332
shows, but it looks like a different situation. Let's wait for a fix for bug
82332 and reopen this if the fix for bug 82332 doesn't fix this as well.

Comment 6

17 years ago
verified dups
Status: RESOLVED → VERIFIED

Comment 7

17 years ago
jst, I am curious if the one-liner I made on bug 82332 solves your crash?
(Reporter)

Comment 8

17 years ago
rbs, I bet it does, but I haven't had a chance to test it out yet...
(Reporter)

Comment 9

17 years ago
Ok, the crash is fixed, but the page at the mentioned URL doesn't load now, no
error message, nothing. When I try to load the URL the previous page remains
displayed but I never see an error message from the XML paser about there being
something wrong with the XML file (which I think there is).

Unduping, and reopening.
Status: VERIFIED → REOPENED
Keywords: crash
Resolution: DUPLICATE → ---
Summary: Crash in nsExpatTokenizer::PushXMLErrorTokens() → Can't load XML file, no error, nothing...
Priority: -- → P2
Target Milestone: --- → mozilla1.0
Target Milestone: mozilla1.0 → mozilla0.9.9
Worksforme, win2k trunk build from 1/17. I bet this got fixed by harishd's XML
parsing architecture change.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
verified on the trunk build 2002-05-07-08-trunk on Windows 2000.
Worksforme. Marking as verified
Status: RESOLVED → VERIFIED
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.