Closed Bug 832687 Opened 12 years ago Closed 12 years ago

can't update a hosted+appcache app

Categories

(Core Graveyard :: DOM: Apps, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 829763

People

(Reporter: julienw, Unassigned)

Details

STR:
* install app in http://everlong.org/mozilla/selfupdatinghosted/
* check for update from Settings

=> in "adb logcat | grep Offline" I see this line :

E/GeckoConsole( 1252): Offline cache manifest magic incorect, URL=http://everlong.org/mozilla/selfupdatinghosted/manifest.appcache

This should happen if the appcache file doesn't start with "CACHE MANIFEST" but this appcache is obviously correct because it installed before...

Problem is : this is the same if the appcache manifest changes, either with a webapp manifest change or without it...
So we never get the update notification for an hosted+appcache app !

This is quite strange because I think we got them in the past so this may be a regression. I'd like a confirmation about this too so marking qawanted.

Blocking on this...

This may be related to Bug 823143 or Bug 830661.
Honza - Any ideas?
Flags: needinfo?(honzab.moz)
The app cache magic error is fixed by the patch in bug 829763
Sounds like this is a dupe then, right?
Status: NEW → RESOLVED
blocking-b2g: tef? → ---
Closed: 12 years ago
Flags: needinfo?(honzab.moz)
Keywords: qawanted
Resolution: --- → DUPLICATE
No longer blocks: b2g-app-updates
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.