All users were logged out of Bugzilla on October 13th, 2018

Move protocol logic in about:telemetry into SymbolicationRequest

RESOLVED FIXED in mozilla21

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: vladan, Assigned: espindola)

Tracking

Trunk
mozilla21
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
All the logic that deals with sending XMLHttpRequests to the Symbolication Server in the about:telemetry page should be in the SymbolicationRequest class.

Rafael requested this be a separate bug in https://bugzilla.mozilla.org/show_bug.cgi?id=831623#c4
Assignee: nobody → respindola
Created attachment 709798 [details] [diff] [review]
patch

I tested this with late writes on a mac. The windows build is still going.
Attachment #709798 - Flags: review?(vdjeric)
(Reporter)

Comment 2

6 years ago
Comment on attachment 709798 [details] [diff] [review]
patch

- If there is an exception in the "handleSymbolResponse" function, will it have a readable name printed in its stack trace or will it be shown as an anonymous function?
- handleSymbolResponse could use a comment header
- you don't want your late writes stacks to have pretty headers? ;)
Attachment #709798 - Flags: review?(vdjeric) → review+
The windows build finished and symbolication worked fine. I will checkin the patch since it fixes this bug and introduces no regressions. I will open followup bugs for these comments.

> - If there is an exception in the "handleSymbolResponse" function, will it
> have a readable name printed in its stack trace or will it be shown as an
> anonymous function?
> - handleSymbolResponse could use a comment header
> - you don't want your late writes stacks to have pretty headers? ;)
https://hg.mozilla.org/mozilla-central/rev/01836b9cdcf1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.