Pdf.js fails to render this file properly: text not visible

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: mikko, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/2606)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 704320 [details]
Screen Shot 2013-01-20 at 9.45.35 AM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130116072953

Steps to reproduce:

Visit URL http://www.sennheiserusa.com/media/productDownloads/factSheets/ANC_MM_Comparison.pdf


Actual results:

Pdf.js does not render the text on the page
Component: Untriaged → PDF Viewer
(Reporter)

Updated

6 years ago
Summary: Pdf.js fails to render this file properly → Pdf.js fails to render this file properly: text not visible
Reproducible also on Ubuntu 12.10, latest Nightly, Aurora and Beta
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Version: 19 Branch → Trunk

Updated

6 years ago
Priority: -- → P2
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]

Updated

6 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/2606
Reproducible also on 64bit platforms
Hardware: x86 → All

Comment 3

6 years ago
Can we add other URLs to this bug, or should we create a new one for each?

Comment 4

6 years ago
Created attachment 717317 [details]
Comparison between pdf.js and Evince

Comment 5

6 years ago
As you can see in my attached file (comparison between pdf.js and Evince) the kerning is very bad and the é character is missing.

Comment 6

6 years ago
Comment on attachment 717317 [details]
Comparison between pdf.js and Evince

The link to the file is http://www.maths.ed.ac.uk/~aar/dreyfus/mawhin.pdf
Works for me in Nightly/Windows
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.