[my] Add Myanmar (Burmese) to the list of languages in advanced font preferences

REOPENED
Unassigned

Status

()

REOPENED
6 years ago
6 months ago

People

(Reporter: gingerbread_man, Unassigned)

Tracking

({parity-ie, parity-opera-mini})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
It's impossible to specify default fonts for this language. Firefox doesn't know how to display the characters in question whenever a particular font is not specified by the page, or font substitution is necessary.

Examples:

1. Text in the address bar, tab titles, toolips and link previews is replaced with code boxes.
http://my.wikipedia.org

2. Code boxes in the list of languages on non-Myanmar Wikipedia pages.
http://en.wikipedia.org/wiki/Burmese_language

3. Code boxes in Bugzilla comments.
https://bugzilla.mozilla.org/show_bug.cgi?id=662746#c29
(Reporter)

Comment 1

6 years ago
Created attachment 704322 [details]
Screenshot
(Reporter)

Updated

6 years ago
Whiteboard: [parity-IE] [parity-Opera]

Comment 2

6 years ago
Created attachment 709657 [details]
Burmese script

Add Google+ Burmese script bugs.
(Reporter)

Comment 3

5 years ago
See bug 709553, comment 5 for an explanation of the issues shown in attachment 704322 [details] and attachment 709657 [details]. This report focuses solely on the need to specify a default font specifically for this language. It's currently affected by the setting for Other Languages, which isn't acceptable because that also affects all sorts of things, like symbols, arrows and emoticons.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Add Myanmar to list of languages in advanced font preferences → [my] Add Myanmar (Burmese) to the list of languages in advanced font preferences
(In reply to Gingerbread Man from comment #0)
> 1. Text in the address bar, tab titles, toolips and link previews is
> replaced with code boxes.
> http://my.wikipedia.org
> 
> 2. Code boxes in the list of languages on non-Myanmar Wikipedia pages.
> http://en.wikipedia.org/wiki/Burmese_language
> 
> 3. Code boxes in Bugzilla comments.
> https://bugzilla.mozilla.org/show_bug.cgi?id=662746#c29

No longer seems to be the case on Windows or Mac at least (didn't test Linux).
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

7 months ago
(In reply to Jonathan Watt [:jwatt] (needinfo? me) from comment #4)
> No longer seems to be the case on Windows or Mac at least (didn't test
> Linux).

First of all, without this implemented, there's no way to specify a custom font for this language. I think that's worth having, especially since other browsers already have this feature.

Secondly, the "Myanmar Text" font was introduced in Windows 8, and isn't available to download for older versions. Back when I tested on Windows 7, the end result was attachment 704322 [details] with other freely downloadable fonts installed (TharLon, Padauk).
Either the page had to specify those exact fonts, or you had to know how to use userContent.css. Only the latter actually results in the user's chosen font being used, and it's not a solution accessible to most.
If someone can test a brand new profile on Windows 7 without "Myanmar Text" installed, then we can rest assured it's no longer an issue. But there's no reason to simply assume the problem is fixed.

Please reopen if you think these are compelling enough reasons.
Flags: needinfo?(jwatt)
(In reply to Gingerbread Man from comment #5)
> If someone can test a brand new profile on Windows 7 without "Myanmar Text"
> installed, then we can rest assured it's no longer an issue. But there's no
> reason to simply assume the problem is fixed.

I didn't "simply" assume FWIW. Nowhere was it mentioned that this bug was windows specific, let alone win7 specific. So as mentioned I tested in windows (10) and mac which seemed sufficient, absent other information about specific platforms to test.

> I think that's worth having, especially since other
> browsers already have this feature.

I just tested the links in comment 0 on win7 in IE, Chrome, Opera and Firefox. All browsers are broken in the same way, showing missing glyph boxes all over. In what sense do other browsers support "this" but Firefox doesn't. Are you saying there are specific steps that can be taken in Chrome, say, to get things to work that cannot be taken in Firefox?

I also tried to install:

https://ftp.mozilla.org/pub/firefox/releases/58.0.2/win32/my/

but even the localized installer was unreadable and unusable. I imagine that win7 users that want to install that localization need to have a suitable font installed just to use their computer in general, in which case Firefox should be able to render text that contains Burmese characters, no?

> Please reopen if you think these are compelling enough reasons.

It seems fine to reopen if we don't have at parity with other browsers, but it's unclear to me that we don't have parity based on my testing.
Flags: needinfo?(jwatt) → needinfo?(gingerbread_man)
FWIW in Chrome's settings under "Add language" there is no Burmese or Myanmar option (at least on win7).
(Reporter)

Comment 8

7 months ago
(In reply to Jonathan Watt [:jwatt] (needinfo? me) from comment #6)
> I didn't "simply" assume FWIW. Nowhere was it mentioned that this bug was
> windows specific, let alone win7 specific.

This bug isn't platform-specific. It's about adding about:config entries and equivalent UI options for Myanmar (Burmese) similar to those that already exist for a myriad of other languages (e.g. font.name.*.ja | about:preferences → Fonts & Colors → Advanced → Fonts for: Japanese).

Being unable to render Myanmar script altogether is specific to Windows 7 and probably some Linux distributions.

> In what sense do other browsers support "this" but Firefox doesn't.

In Internet Explorer, click the cog wheel, then Internet Options. On the General tab, click the Fonts button. Next to "Language script:" you can pick Myanmar. There you can select freely downloadable fonts like TharLon or Padauk.

I don't know about Chrome; I made no mention of it. Presto-based Opera also had this feature, but lost it in transition.

And like I said, Firefox has this feature for other languages. Why not have internal parity?
Status: RESOLVED → REOPENED
Flags: needinfo?(gingerbread_man)
Resolution: WORKSFORME → ---
Whiteboard: [parity-IE] [parity-Opera] → [parity-IE] [parity-presto Opera]
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-ie, parity-opera-mini
Whiteboard: [parity-IE] [parity-presto Opera]
You need to log in before you can comment on or make changes to this bug.