variables view sorts an array elements taking the indexes as strings

RESOLVED DUPLICATE of bug 828664

Status

RESOLVED DUPLICATE of bug 828664
6 years ago
5 months ago

People

(Reporter: Optimizer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
when you expand an array in the variables view, you get this :

V array_foo
  > 0
  > 1
  > 11
  > 12
  > 13
  .
  .
  > 18
  > 19
  > 100
  > 2
  > 20
  > 21

and so on.

Basically the indexes are sorted as strings, not numbers.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 828664

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.