no hardware acceleration support for WebM on HD4000 causes high power use

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: mayankleoboy1, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130120 Firefox/21.0
Build ID: 20130120030952

Steps to reproduce:

Reported by Anandtech here : http://www.anandtech.com/show/6674/getting-the-best-out-of-an-ivy-bridge-htpc-windows-8-madvr-and-more/4


"If you are on Windows, and prefer to use HTML5, it is better to avoid Mozilla Firefox because the WebM version consumes the most power at the wall (due to lack of hardware accelerated decode) while providing only a 720p stream. "




Actual results:

Win7 + Firefox+720P WebM video uses more power than any other combination.


Expected results:

Provide hardware decode support for WebM.
Component: Untriaged → Video/Audio
Product: Firefox → Core

Comment 1

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130120 Firefox/21.0
Build Id: 20130120030952

It works for me on 20.01.2013 Nightly build. I've tested by opening a 720 webM video (on youtube and vimeo) and I see no difference in CPU usage between Firefox and Chrome. I've performed the same steps on the latest Nightly (from 25.01.2013) and the results are identical.

Could you please provide some extra information regarding this issue? Do you have any add-on installed?
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 2

6 years ago
as said in comment 0 , this is from a test done by Anandtech.com , which i happened to read.
Since his comments were so negative towards FF, i decided to file a bug on that. I personally do not have the necessary hardware to test.

The power consumption for FF+WebM video is "Win7-HTML5 WebM (720P)".  

Do you use a Ivy bridge CPU with the integrated HD4000 GPU ?
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 3

4 years ago
this is probably solved now by the large A/V changes done.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.