Mozilla wont start (errorcode 139) for some users

VERIFIED DUPLICATE of bug 42184

Status

SeaMonkey
Installer
--
blocker
VERIFIED DUPLICATE of bug 42184
17 years ago
13 years ago

People

(Reporter: Dennis Haney, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-3 i686)
BuildID:    0.9 (cant get date, it wont start)

Mozilla wont start for some users even though the setup is completly the same.

starting the mozilla gives this reply:

grerr ~/ > mozilla
/usr/local/dikunix/work/mozilla/linux/mozilla/run-mozilla.sh
/usr/local/dikunix/work/mozilla/linux/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/dikunix/work/mozilla/linux/mozilla
 
LD_LIBRARY_PATH=/usr/local/dikunix/work/mozilla/linux/mozilla:/usr/local/dikunix/work/mozilla/linux/mozilla/plugins:/usr/local/dikunix/lib:/usr/local/projects/disk02/algorithm/LEDA-4.1-Linux:/lib:/usr/lib:/usr/local/opt/PostgreSQL/lib:/usr/local/lib:/usr/local/stow/lib:/usr/local/store/lib
    
LIBRARY_PATH=/usr/local/dikunix/work/mozilla/linux/mozilla:/usr/local/dikunix/work/mozilla/linux/mozilla/components
       SHLIB_PATH=/usr/local/dikunix/work/mozilla/linux/mozilla
          LIBPATH=/usr/local/dikunix/work/mozilla/linux/mozilla
       ADDON_PATH=/usr/local/dikunix/work/mozilla/linux/mozilla
      MOZ_PROGRAM=/usr/local/dikunix/work/mozilla/linux/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Exit 139

It usually takes a half second or so to give the errorcode.

grerr ~/ > which mozilla
/usr/local/dikunix/bin/mozilla

grerr ~/ > ls -l /usr/local/dikunix/bin/mozilla
lrwxrwxrwx   1 leopold  user           39 May  8 10:00
/usr/local/dikunix/bin/mozilla -> ../../../work/mozilla/linux/bin/mozilla*

grerr ~/ > cat /usr/local/dikunix/work/mozilla/linux/bin/mozilla
dist_bin=/usr/local/dikunix/work/mozilla/linux/mozilla
script_args=""
moreargs=""
debugging=0
MOZILLA_BIN="mozilla-bin"
...
eval "set -- $moreargs"
echo $dist_bin/run-mozilla.sh $script_args $dist_bin/$MOZILLA_BIN "$@"
exec $dist_bin/run-mozilla.sh $script_args $dist_bin/$MOZILLA_BIN "$@"


Starting with -d opens up ddd which complains about not being able to locate
libgkgfx.so which is right in front of it, so no luck there.

The really wierd part is that it will start for some users (fx. the user who
installed it), but as stated not for others (the majority).

Reproducible: Always
Steps to Reproduce:
1. Start mozilla

Actual Results:  Error code 139

Expected Results:  Mozilla starting ;)
How was Mozilla installed?  Was it from tarball?  If so did the installer run 
./regxpcom && ./regchrome ?

Updated

17 years ago
QA Contact: gemal → gbush
d.a.v.h@usa.net - could you drop by and give us some more info, as bzbarsky 
requests? :-)

Gerv
(Reporter)

Comment 3

17 years ago
I'll get back to you when we've installed 0.9.1 (or .2) as 0.9 was installed,
which was with the official tar.gz file and what was written in the readme notes
were followed point by point.
I did however try to install 0.9.1 as myself in another dir, and there were no
problems running it (except auto proxy is still broken), but didnt try with
other users.
(Reporter)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 42184 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verify duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.