Closed Bug 832949 Opened 7 years ago Closed 7 years ago

Disable common Organize options when the Downloads view is in use

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: mak, Assigned: mano)

References

Details

Attachments

(1 file)

New bookmark, New folder, New separator and Move... commands in Organize should be disabled if the current view doesn't support them.

This is quite confusing, I found this bug while reading feedback on the new manager.
Comment on attachment 705383 [details] [diff] [review]
patch

Review of attachment 705383 [details] [diff] [review]:
-----------------------------------------------------------------

Nice fix, thank you!

::: browser/components/places/content/controller.js
@@ +1617,2 @@
>    function updatePlacesCommand(aCommand) {
> +    goSetCommandEnabled(aCommand, placesController && placesController.isCommandEnabled(aCommand));

please indent as
 goSetCommandEnabled(aCommand, placesController &&
                               placesController.isCommandEnabled(aCommand));
Attachment #705383 - Flags: review?(mak77) → review+
Comment on attachment 705383 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): downloads panel feature
User impact if declined: some commands in the Library menus are enabled but don't work
Testing completed (on m-c, etc.): m-i, local
Risk to taking this patch (and alternatives if risky): limited, trivial change
String or UUID changes made by this patch: none
Attachment #705383 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ff45a29c2072
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 705383 [details] [diff] [review]
patch

Approving on aurora, low risk patch helps with user annoyance for the new feature
Attachment #705383 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
When verifying this bug I found a situation where the common Organize options are still enabled if the Downloads view is in focus.

Steps to reproduce:
1. Launch Firefox and perform several downloads.
2. Open the Downloads View using the keyboard shortcut (Ctrl/Cmd+ J on Windows and Mac OS X or Ctrl+Shift+Y on Ubuntu)
3. Click on the Bookmarks Toolbar and after that, in the right side click on any of the bookmarks
4. Move the focus from the Library window
5. Focus the Downloads View again by using the keyboard shortcut
6. Click on the Organize button to see the options.

Expected results:
New bookmark, New folder, New separator and Move options are disabled.

Actual results:
New bookmark, New folder, New separator and Move options are enabled.

Marco, would you prefer me to file a new bug or to reopen this one?
(In reply to Simona B [QA] from comment #8)
> Marco, would you prefer me to file a new bug or to reopen this one?

please file a new blocker bug, it's likely we missed updating commands somewhere.
Depends on: 836211
Thanks Marco, filed Bug 836211.
Verified as fixed on Firefox 20 RC - the common Organize options are disabled when the Downloads view is in focus.
Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Build ID: 20130326150557

Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
You need to log in before you can comment on or make changes to this bug.