Last Comment Bug 83300 - show busy cursor when pasting and other slow actions
: show busy cursor when pasting and other slow actions
Status: RESOLVED EXPIRED
[ui]
: helpwanted, polish, pp
Product: SeaMonkey
Classification: Client Software
Component: Composer (show other bugs)
: Trunk
: x86 Windows 2000
: -- enhancement with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://people.netscape.com/sujay/larg...
Depends on:
Blocks: 91351
  Show dependency treegraph
 
Reported: 2001-05-30 08:37 PDT by timeless
Modified: 2014-04-26 02:24 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description timeless 2001-05-30 08:37:43 PDT
[5/29-04 w32 talkback]
steps:
copy contents of nsTableFrame.cpp (4290 lines)
go to a page that has a text area (bugzilla comment field). paste.
[hover over reload button]

On my p2/450 w2k it took 62 seconds and I had the Ibeam for the entire time.

expect: busy cursor since I can't click any of the nav buttons.
Comment 1 sujay 2001-05-30 09:07:36 PDT
I also noticed this during performance testing...I've included a URL
above that I used.

I also see the same problem when opening a file like the one above.
Comment 2 doctor__j 2001-05-30 10:38:45 PDT
When I paste huge amount of text using right-click pop-up menu, the menu stays
there and the world freezes over...
Comment 3 rubydoo123 2001-05-30 11:40:16 PDT
handing over to brade and cc charley -- I vaguely remember somebody saying 
something about not being able to do this
Comment 4 Kathleen Brade 2001-05-30 11:43:33 PDT
I see a watch cursor on my Mac build.  Is this a windows-specific bug?
Comment 5 Simon Fraser 2001-05-30 11:47:27 PDT
Mac shows a watch cursor whenever it's away from the main event look for any 
length of time. So these kinds of bugs will differ across platforms.
Comment 6 Charles Manske 2001-05-30 12:32:52 PDT
This is a general problem needed in many places -- we don't use the busy
cursor at all!
Anyone know if and how we show a busy cursor?
Comment 7 James Green 2001-05-30 12:54:00 PDT
Hrm, wouldn't it be better to fix pasting speed rather than indicate to the user
that we're just darned slow?

If I pasted a short amount of text, setting the cursor then re-setting the
cursor is going to slow it down slightly - you have to ask, why at all. I guess
you also run to risk of a bug creeping in that stops the mouse cursor being
turned back to normal again on quick pastes.
Comment 8 Garth Wallace 2001-05-30 14:22:25 PDT
I doubt that setting the cursor twice would slow anything down much. It's O(1),
and it doesn't make a significant impact in any app I've seen.
Comment 9 timeless 2001-05-30 14:42:52 PDT
bryner says it's window.setCursor("wait");
Comment 10 Charles Manske 2001-05-31 08:56:53 PDT
If it's that easy, we definitely should do this before release!
Nominating for 0.9.2
Comment 11 rubydoo123 2001-06-08 11:11:58 PDT
1.0
Comment 12 Syd Logan 2001-09-12 13:29:57 PDT
spam composer change
Comment 13 Asa Dotzler [:asa] 2001-12-03 10:34:14 PST
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Comment 14 Asa Dotzler [:asa] 2001-12-03 17:19:13 PST
don't move bugs that are in the 1.0 dependency tree. sorry.

Comment 15 Kathleen Brade 2002-02-05 14:59:42 PST
balancing milestones
Comment 16 Kathleen Brade 2003-01-10 08:18:21 PST
-->
note: it'd be better to address the performance issues before addressing this
(since more people will benefit from the perf fixes than those who would see the
cursor)
Comment 17 Robert Kaiser 2009-06-14 07:31:27 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 18 Robert Kaiser 2009-06-14 07:35:50 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 19 Robert Kaiser 2009-06-14 07:49:49 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 20 Robert Kaiser 2009-06-14 07:52:35 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 21 Robert Kaiser 2009-06-14 07:52:50 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 22 Robert Kaiser 2009-06-14 07:56:56 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 23 Robert Kaiser 2009-06-14 08:00:05 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 24 Robert Kaiser 2010-04-28 13:27:12 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420

Note You need to log in before you can comment on or make changes to this bug.