consuming 500MB of memory in windows OS with just one session has flashplayer and no addons at all

VERIFIED INCOMPLETE

Status

()

Core
Plug-ins
VERIFIED INCOMPLETE
6 years ago
5 years ago

People

(Reporter: madasamy, Unassigned)

Tracking

17 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Started using youtube.com and started playing one video in firefox 17 version under Windows OS 64 bit


Actual results:

AFter the 5 mins video ends, i checked the memory consumption in task manager which is huge as 470 MB and the adobe flashplayer memory consumption has been more than 100 MB which is always unusual. If i keep it idle, the memory consumption keep on increasing till 600 MB sometimes and the CPU gets running faster


Expected results:

The memory consumption should be nominal and as low as the previous releases of Mozilla firefox like 15 and 14.  Also the memory leak problem should be found out and solved for idle tabs.
(Reporter)

Updated

6 years ago
Severity: normal → major
tracking-firefox18: --- → ?
Component: Untriaged → Tabbed Browser
Keywords: 64bit
Priority: -- → P2

Updated

6 years ago
Component: Tabbed Browser → Plug-ins
Keywords: 64bit
Product: Firefox → Core

Comment 1

6 years ago
Could you test with a fresh profile, please:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

In addition, try with Hardware Acceleration disabled (http://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration).
Severity: major → normal
tracking-firefox18: ? → ---
Flags: needinfo?(madasamy.murugan)
Priority: P2 → --

Comment 2

6 years ago
Loic, those aren't really useful data points. We want this to work whether or not acceleration is enabled.

madsamy, what version of Flash are you using (from about:plugins)? Is it possible that you upgraded Flash recently?

Since different youtube videos use different playback mechanisms, can you paste the exact video you are using to test?

Also pasting information from about:memory might be useful in diagnosing whether this is a leak, "normal but large" memory usage, or something else.
(Reporter)

Comment 3

5 years ago
Hi Guys,
Thanks for the replies. But i do not have the same setup as i had before.

1. I have cleared the profile and created a new profile just after a month.
2. I have cleared the cache folders many times.
3. There were some upgrades from firefox which have been done automatically in between. 

Hence, i am not sure whether my current setup would help analyzing this issue.

With the current setup,i am getting 300 MB usage of my memory and Adobe consumes around 100 MB which i think still a huge amount. If you want, i can play some videos and get back to you with the info tat you have asked for.

Thanks,
Madasamy M.
Flags: needinfo?(madasamy.murugan)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

5 years ago
today, i tried loading my firefox with little stuffs. "http://www.youtube.com/watch?v=Keol9LQKFl8" This is the video i played. 

will try to attach the task manager session here.
In my firefox, there is just one youtube session ( tab ) and facebook tab which uses flash. apart from that, i don have any sessions which uses flash. 

the total number of sessions is 7 when i tested this.

let me know if any other info needed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.