Unable to get data connection due to phone thinking it is roaming

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: gerard-majax, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: QARegressExclude)

(Reporter)

Description

6 years ago
When your provider is using another provider's network, like Free Mobile in France, for roaming where it has no coverage, it is impossible to get data connection unless enabling data roaming in settings. The checkRoamingBetweenOperators() is successfully executed, since the roaming indicator is not present anymore.

This is happening on Nexus S, Otoro and Unagi.
(Reporter)

Updated

6 years ago
Blocks: 787967
Same carrier, I confirm I've always had to enable roaming for my Otoro and Unagi devices.  That’s OK for me but real-world users would probably never think of enabling roaming for that (or wouldn't enable it because of the message that says it will cause additional charges).
(Reporter)

Comment 2

6 years ago
As far as I remember, it's notified by the provider that you might have to enable roaming. Maybe a nicer solution would be, like I see on CyanogenMod (and mybe stock AOSP), to have a « National Data Roaming » option, that could be automatically set by checkRoamingBetweenOperators() when we have a different network identifier but same country.

This, of course, if the data roaming can't be enforced from the RIL JS code.
Be aware that in some situation, this is not "free" roaming either.

Example in Canada. WIND has roaming agreement with a national carrier (shows a "WIND Away" on the phone in lieu of carrier name). The data cost *a lot* when roaming on that carrier. So we should make sure that whatever solution is implemented that we don't assume the roaming data connection is free.
I am worrying about if this would block shira(v1.0.1)?

dcoloma:
Is there any people can help to investigate more on target market?
blocking-b2g: --- → shira?
Keywords: qawanted
Brazil has a very particular roaming situation, as it has roaming across States. It sounds like this deserve attention. David, can we test this in Brazil and also with a MVO in Movistar Spain?
Flags: needinfo?(dpv)

Comment 6

6 years ago
If this does impact TEF, this bug would be tef+. Waiting on feedback though.
blocking-b2g: shira? → tef?
We saw a similar issue in October during on site testing in Brazil and it was fixed by then. I am not 100% sure if the issue is the same I just include here the bug reference number in case it helps:
https://bugzilla.mozilla.org/show_bug.cgi?id=797972
Hi, 

Retested with MVO in Spain (different MNC), and works fine (data connection is ok, and no "roaming situation" is detected). 

We're checking how to test this in Vivo, we'll let you know asap. 

Rgds!
David
Flags: needinfo?(dpv)

Updated

6 years ago
blocking-b2g: tef? → -

Comment 9

6 years ago
(In reply to David Palomino [:dpv] from comment #8)
> We're checking how to test this in Vivo, we'll let you know asap. 

Please re-nom if/when this is reproduced and deemed critical.
Waiting to hear back from dpv before removing QA Wanted.
Flags: needinfo?(dpv)
Hi Naoki, 

We're arranging some tests in Brazil, but this will take some time because of logistics difficulties. For us, as Daniel and Beatriz have already commented, it could be an issue for Brazil. 

As commented by Beatriz, the issue found in Brazil time ago: 
https://bugzilla.mozilla.org/show_bug.cgi?id=797972

It was already fixed, but we have to check if there's a regression. 

BTW, as commented in comment#8, it was retested with a MVO SIM card in Spain (Tuenti, in Spain, with different MNC), and behavior was ok. 

We let you know as soon as we'd have any testing update in Brazil. 

Thanks!
David
Flags: needinfo?(dpv)
David - Do you have any updates on testing update you mention in comment 11 for Vivo?
Flags: needinfo?(dpv)
Hi, 

Testing with Vivo was delayed indeed. We hope to finally execute, but it's not something we can do at short term. 

thanks, 
David
Flags: needinfo?(dpv)

Updated

5 years ago
Whiteboard: QARegressExclude
David, any update here? :-)
Flags: needinfo?(dpv)
Hi, 

We're trying to get a SIM card out of SP (with different MNC).  I think tomorrow we'll be able to have some results here... 

thks!
David
Hi again, 


Retested today with different MNC SIM Card (tested in SP, with SIM card from Campinhas), and worked fine. No roaming indication shown, and data was available. 

Leo build 06/07:
Gecko revision : 08e8a7bbebec924c24a5187a3c0b2ef1ef6d08da
Gaia revision : e2346ca0297f40547e64a7eebc4bd2e4a4cdaf86
QC commercial RIL : AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.115

resolved/fixed
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dpv)
Resolution: --- → FIXED
moving to works for me only because we don't know what patch fixed this bug
Keywords: qawanted
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.