[SMS] Multi-page(over 160chars) SMS works incorrectly(converted to single-page SMSs).

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: leo.bugzilla.gecko, Unassigned)

Tracking

({regression})

unspecified
x86
Windows XP
regression
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(URL)

(Reporter)

Description

5 years ago
When a device send multi-page SMS(over 160chars), SMS data separated to several single page SMSs and then transmitted to other device. So, MT device received several single-page SMSs.  

The other way, when a device received multi-page SMS from other device(or test tool) sometimes the device reset occurred.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
Group: partner-confidential → mozilla-corporation-confidential
Group: mozilla-corporation-confidential
reporter commented that it worked on Jan 4th, and did not work on Jan 10th.
Keywords: regression
Can you clarify what the problem is?

Do you expect the text "bubble" to combine multiple text messages into a single one? Or are the messages showing up as separate threads?
(Reporter)

Comment 4

5 years ago
This problem is related with message-segments not UI problem.
And fixed at "AU_LINUX_GECKO_ICS_STRAWBERRY.01.00.00.19.182".
...
c019be5 SMS: Fix crash issue for incoming multisegment SMS
...
Thanks.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
blocking-b2g: leo? → leo+
is there a commit that needs to be uplifted to v1-train for this to be fixed?
Flags: needinfo?(nobody)
Flags: needinfo?(leo.bugzilla.gecko)
Flags: needinfo?(leo.bugzilla.gaia)
Flags: needinfo?(nobody)
ping, can we mark this as fixed in the effected branches?

Comment 7

5 years ago
Hi,

This issue is not reproducible with the latest binary.
Once gecko team need to confirm this.

Thanks,
Leo
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 8

5 years ago
remove need info
Flags: needinfo?(leo.bugzilla.gecko)

Updated

4 years ago
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+

Updated

4 years ago
Blocks: 918976
You need to log in before you can comment on or make changes to this bug.