[Settings] Text overlap between device name and switch icon on BT menu

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Unassigned)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18+)

Details

(Whiteboard: [TD-23548])

Attachments

(3 attachments, 1 obsolete attachment)

322 bytes, text/x-patch
Details
34.19 KB, image/png
Details
175 bytes, text/html
arthurcc
: review+
Details
(Reporter)

Description

5 years ago
1. Title : Text overlap between device name and switch icon on BT menu
2. Precondition : setting - bluetooth - rename my device
3. Tester's Action : input long text
4. Detailed Symptom (ENG.) : text overlap with switch icon
6. Expected : 
7. Reproducibility: Y
1)Frequency Rate : 100%
8. Gaia revision : a03f7b532e9998e646d55f93a0fc03a04d7ca7d9
Hardcoded the length of the name is not a good idea since the length depends on style and screen resolutions. The style for list items should have handled text overflow. I noted that it works after the device gets paired. We should find the root instead of trimming the device name.
(Reporter)

Comment 3

5 years ago
Created attachment 746766 [details]
patch
Attachment #746766 - Flags: review?(ehung)
Created attachment 746882 [details]
Patch v1

Simply inherits the overflow settings from ul.

Comment 5

5 years ago
(In reply to Arthur Chen [:arthurcc] from comment #4)
> Created attachment 746882 [details]
> Patch v1
> 
> Simply inherits the overflow settings from ul.

It's just a patch for device list overlap. This issue aleady raised on Bug 861768.
In my patch, I modifed the subline overlap of my devince name.
I attached the screenshot. plz check again.
(Reporter)

Comment 6

5 years ago
Created attachment 747217 [details]
screenshot applied  Patch v1

Comment 7

5 years ago
Comment on attachment 746766 [details]
patch

redirect to Arthur. Thanks!
Attachment #746766 - Flags: review?(ehung) → review?(arthur.chen)
Comment on attachment 746766 [details]
patch

Hyuna, thank you for the screenshot! I misunderstood the issue. Regarding your patch, please check my comment in github.
Attachment #746766 - Flags: review?(arthur.chen)
Pavel, could you give some input here? I would like to make sure we won't mess up anything when trying to modify |right| value in |ul li > label:not([for]) + small|. Thanks!
Flags: needinfo?(pivanov)
Hi,
I think we just need to increase the |right: 6rem| to |right: 9rem| here:
https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/style/lists.css#L94

and also we nee to do the sam think but for the left [RTL] here: 
https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/style/lists.css#L447

Hoper this one helps :)
Flags: needinfo?(pivanov)
Thanks Pavel! 

Hyuna, could you update the patch based on Pavel's comment? Thanks!
(Reporter)

Comment 12

5 years ago
Created attachment 748619 [details]
patch_v2

plz check updated patch_v2
Attachment #746766 - Attachment is obsolete: true
Attachment #748619 - Flags: review?(arthur.chen)
Comment on attachment 748619 [details]
patch_v2

Thanks for the patch. r=me
Attachment #748619 - Flags: review?(arthur.chen) → review+
master: https://github.com/mozilla-b2g/gaia/commit/7cf075f1b3fb9ccd00bc2f305b7ba1381ab7f012
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 15

5 years ago
(In reply to Arthur Chen [:arthurcc] from comment #14)
> master:
> https://github.com/mozilla-b2g/gaia/commit/
> 7cf075f1b3fb9ccd00bc2f305b7ba1381ab7f012

Plz land the patch into v1-train
blocking-b2g: --- → leo?
Triage -Not a blocker considering quite a long name is required for this bug to show.
blocking-b2g: leo? → ---
tracking-b2g18: --- → +

Updated

5 years ago
Whiteboard: [TD-23548]
Target Milestone: --- → 1.1 QE2

Updated

5 years ago
Duplicate of this bug: 849066
You need to log in before you can comment on or make changes to this bug.