Please use git tags for nightly QA FFOS builds

RESOLVED WORKSFORME

Status

Release Engineering
General Automation
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: m1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It would be very helpful if git tags could be created on g.m.o representing the nightly QA FFOS builds, for each git repository on g.m.o that contributes to that build.

This would enable downstream users to understand how a given QA nightly build relates to their automated builds.

Two use cases in particular are of interest:
1) Enabling an easy way to answer the question, "What/when was the most recent QA build in the current branch for project X?"
2) Enabling downstream users to optionally lock their manifests to the most recent QA build.   This could also be done with branching but that feels like more work.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
per email w/tchung and mvines, moving this to RelEng, while we figure out the ask here. 

We already generate sources.xml manifest for each nightly build, and place that sources.xml alongside the nightly build. This sources.xml contains the changesets for all repos, not just gaia. And contains both git changeset *and* hg changeset, so that both Mozilla and external partners can figure out what exactly has
changed in each nightly.

For example, see:  http://ftp.mozilla.org/pub/mozilla.org/b2g/manifests/latest/
Component: Builds → Release Engineering: Automation (General)
Product: Boot2Gecko → mozilla.org
QA Contact: catlee
Version: unspecified → other
(Reporter)

Comment 2

5 years ago
Having to download/parse an external manifest is not convenient.  PITA aside, that ftp site may be down or not accessible for countless reasons.

For #1 I'd like git to do the work for me, and it wants to!  Run |git describe --tag --match MOZ_NIGHTLY_TAG_PREFIX_*| in gecko, gaia, or any other moz-managed repo.   This is very convenient for all developers, works on any clone, and requires no additional tooling or external dependencies.

The only argument for not tagging seems to be 'git tag pollution'.  I appreciate that argument because we suffer the same [1].   However it's not really a big deal once folks get over it (shocked me the first time, but I have a nice callous built up now and it's water under the bridge).  Plus slipping a -q to |repo sync| makes this go away nicely.   


[1] https://www.codeaurora.org/gitweb/quic/la/?p=platform/frameworks/base.git;a=tags
per meeting w/mvines and others today, the root cause behind the ask here is not so much about known-tags-per-nightly-build... but more about knowing which changesets are on known-good-enough-for-dogfooding-nightly-build (and hence, which nightly builds safe enough for downstream users to pickup and use).

mvines+joduinn have manual workaround in place for now, so brainstorming some options to automate this.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
blocking-b2g: leo? → ---
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.