Assertion failure: !recorded, at toolkit/components/telemetry/Telemetry.cpp:1986

RESOLVED DUPLICATE of bug 832330

Status

()

Toolkit
Telemetry
RESOLVED DUPLICATE of bug 832330
5 years ago
5 years ago

People

(Reporter: njn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Recently I've been getting the following assertion failure occasionally on shutdown.  It happens in trunk builds, on my Linux64 machine, perhaps 20% of the time.

The cause seems to be that RecordShutdownStartTimeStamp() is called twice.

Assertion failure: !recorded, at /home/njn/moz/mi1/toolkit/components/telemetry/Telemetry.cpp:1986
#0  0x00007fb1eb6fd83d in nanosleep ()
    at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fb1eb6fd6dc in __sleep (seconds=0)
    at ../sysdeps/unix/sysv/linux/sleep.c:138
#2  0x00007fb1e615342d in ah_crap_handler (signum=11)
    at /home/njn/moz/mi1/toolkit/xre/nsSigHandlers.cpp:88
#3  0x00007fb1e615f541 in nsProfileLock::FatalSignalHandler (signo=11, 
    info=0x7fff99610ab0, context=0x7fff99610980) at nsProfileLock.cpp:190
#4  <signal handler called>
#5  mozilla::RecordShutdownStartTimeStamp ()
    at /home/njn/moz/mi1/toolkit/components/telemetry/Telemetry.cpp:1986
#6  0x00007fb1e7bf7a02 in nsAppStartup::Quit (this=0x7fb1d80e3240, aMode=1)
    at /home/njn/moz/mi1/toolkit/components/startup/nsAppStartup.cpp:383
#7  0x00007fb1e7bf840b in nsAppStartup::ExitLastWindowClosingSurvivalArea (
    this=0x7fb1d80e3240)
    at /home/njn/moz/mi1/toolkit/components/startup/nsAppStartup.cpp:526
#8  0x00007fb1e7bf8c57 in nsAppStartup::Observe (this=0x7fb1d80e3240, 
    aSubject=0x0, aTopic=0x7fb1e9b52db8 <.L.str7> "xul-window-destroyed", 
    aData=0x0)
    at /home/njn/moz/mi1/toolkit/components/startup/nsAppStartup.cpp:651
#9  0x00007fb1e7bf8d0f in non-virtual thunk to nsAppStartup::Observe(nsISupports*, char const*, unsigned short const*) (this=0x7fb1d80e3250, aSubject=0x0, 
    aTopic=0x7fb1e9b52db8 <.L.str7> "xul-window-destroyed", aData=0x0)
    at /home/njn/moz/mi1/toolkit/components/startup/nsAppStartup.cpp:672
#10 0x00007fb1e85e5399 in nsObserverList::NotifyObservers (
    this=0x7fb1c90c91f8, aSubject=0x0, 
    aTopic=0x7fb1e9b52db8 <.L.str7> "xul-window-destroyed", someData=0x0)
    at /home/njn/moz/mi1/xpcom/ds/nsObserverList.cpp:99
#11 0x00007fb1e85e7774 in nsObserverService::NotifyObservers (
    this=0x7fb1dcedd790, aSubject=0x0, 
    aTopic=0x7fb1e9b52db8 <.L.str7> "xul-window-destroyed", someData=0x0)
    at /home/njn/moz/mi1/xpcom/ds/nsObserverService.cpp:161
#12 0x00007fb1e7bc94a3 in nsXULWindow::Destroy (this=0x7fb1ce2fc8e0)
    at /home/njn/moz/mi1/xpfe/appshell/src/nsXULWindow.cpp:522
#13 0x00007fb1e7bdb0e7 in nsWebShellWindow::Destroy (this=0x7fb1ce2fc8e0)
    at /home/njn/moz/mi1/xpfe/appshell/src/nsWebShellWindow.cpp:754
#14 0x00007fb1e7bbd759 in nsChromeTreeOwner::Destroy (this=0x7fb1ccf126f0)
    at /home/njn/moz/mi1/xpfe/appshell/src/nsChromeTreeOwner.cpp:348
#15 0x00007fb1e7bbd78c in non-virtual thunk to nsChromeTreeOwner::Destroy() (
    this=0x7fb1ccf126f8)
    at /home/njn/moz/mi1/xpfe/appshell/src/nsChromeTreeOwner.cpp:349
#16 0x00007fb1e716a401 in nsGlobalWindow::ReallyCloseWindow (
    this=0x7fb1cd7cd800) at /home/njn/moz/mi1/dom/base/nsGlobalWindow.cpp:7011
#17 0x00007fb1e719b20b in nsCloseEvent::Run (this=0x7fb1c7e14c00)
    at /home/njn/moz/mi1/dom/base/nsGlobalWindow.cpp:6800
#18 0x00007fb1e86476a6 in nsThread::ProcessNextEvent (this=0x7fb1eb579bf0, 
    mayWait=false, result=0x7fff9961187e)
    at /home/njn/moz/mi1/xpcom/threads/nsThread.cpp:627
#19 0x00007fb1e85b9719 in NS_ProcessNextEvent_P (thread=0x7fb1eb579bf0, 
    mayWait=false) at nsThreadUtils.cpp:238
#20 0x00007fb1e816bd2d in mozilla::ipc::MessagePump::Run (
    this=0x7fb1dce4a080, aDelegate=0x7fb1eb5e0f90)
    at /home/njn/moz/mi1/ipc/glue/MessagePump.cpp:82
#21 0x00007fb1e86aeaf6 in MessageLoop::RunInternal (this=0x7fb1eb5e0f90)
    at /home/njn/moz/mi1/ipc/chromium/src/base/message_loop.cc:215
#22 0x00007fb1e86aea75 in MessageLoop::RunHandler (this=0x7fb1eb5e0f90)
    at /home/njn/moz/mi1/ipc/chromium/src/base/message_loop.cc:208
#23 0x00007fb1e86aea4d in MessageLoop::Run (this=0x7fb1eb5e0f90)
    at /home/njn/moz/mi1/ipc/chromium/src/base/message_loop.cc:182
#24 0x00007fb1e7f80391 in nsBaseAppShell::Run (this=0x7fb1d80deef0)
    at /home/njn/moz/mi1/widget/xpwidgets/nsBaseAppShell.cpp:163
#25 0x00007fb1e7bf76d2 in nsAppStartup::Run (this=0x7fb1d80e3240)
    at /home/njn/moz/mi1/toolkit/components/startup/nsAppStartup.cpp:288
#26 0x00007fb1e613f998 in XREMain::XRE_mainRun (this=0x7fff99612008)
    at /home/njn/moz/mi1/toolkit/xre/nsAppRunner.cpp:3823
#27 0x00007fb1e6140922 in XREMain::XRE_main (this=0x7fff99612008, argc=4, 
    argv=0x7fff99613588, aAppData=0x7fff99612248)
    at /home/njn/moz/mi1/toolkit/xre/nsAppRunner.cpp:3890
#28 0x00007fb1e61411af in XRE_main (argc=4, argv=0x7fff99613588, 
    aAppData=0x7fff99612248, aFlags=0)
    at /home/njn/moz/mi1/toolkit/xre/nsAppRunner.cpp:4093
#29 0x0000000000402f80 in do_main (argc=4, argv=0x7fff99613588, 
    xreDirectory=0x7fb1eb530300)
    at /home/njn/moz/mi1/browser/app/nsBrowserApp.cpp:195
#30 0x0000000000402748 in main (argc=4, argv=0x7fff99613588)
    at /home/njn/moz/mi1/browser/app/nsBrowserApp.cpp:388
I think Rafael was moving bits of code around in this area and there were some assertions.  Rafael, does this assertion look familiar?
Marking this as a duplicate of 832330 where I will try to enable this assert again. The shutdown process is fairly convoluted and I still don't understand how we "shutdown twice" :-(
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 832330
You need to log in before you can comment on or make changes to this bug.