[Email] Search breaks on empty subject; visible in "subject" and "all" search filters

VERIFIED FIXED

Status

Firefox OS
Gaia::E-Mail
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Leo, Assigned: asuth)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

(Whiteboard: testrun 3)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
1. Title : Email list Search results for ALL and SUBJECT fields are empty
2. Precondition : Email account has to be configured and some emails should be present with subject.
3. Tester's Action : Email - Open Inbox list - Select search field - enter some text which is present in the existing mail (Subject)- click on subject and All fields.
4. Detailed Symptom (ENG.) :Not listing the mails which matches the search string in Subject and All fields
5. Expected :It should populate the list of returned results matching the search in ALL and Subject fields also.
6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Revision: a03f7b532e9998e646d55f93a0fc03a04d7ca7d9
(Assignee)

Comment 1

6 years ago
Please provide logcat and account type info:
https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo

Additionally, please describe the actual text string that was searched for and provide an example of the text that it was expected to match against.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 2

6 years ago
Issue Not reproduced in 
Gaia Revision: 7b8dea7e7ec377a2143151bbe5e9998d87f7b36d.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Resolution: --- → WORKSFORME

Comment 3

6 years ago
Verified reproduceable in Unagi build 20130125070201
3/3

Dec 5th Kernel


Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18/rev/94a2d6fcdfde

Gaia:   6369dbf33b622faf4b4d176fed30b77c5c319dfc
Whiteboard: testrun 3
(Assignee)

Comment 4

6 years ago
(In reply to Andrew Sutherland (:asuth) from comment #1)
> Please provide logcat and account type info:
> https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo
> 
> Additionally, please describe the actual text string that was searched for
> and provide an example of the text that it was expected to match against.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
I attempted to search using the term Twitter.  Searching by To returned results, as did searching by Body.  Searching by Subject returned a blank page even though there are valid results to be had from the search.

This is from the same device version as mlevin's.
Oops, mlevin -> mdaniloff
(Assignee)

Comment 8

6 years ago
Inferred from the log that we must be throwing an exception that sadly is not caught and logged and it had to do with the subject.  Then I remembered we normalize subjects to be null!
Assignee: nobody → bugmail
Status: REOPENED → ASSIGNED
Summary: [Email] Email list Search results for ALL and SUBJECT fields are empty → [Email] Search breaks on empty subject; visible in "subject" and "all" search filters
(Assignee)

Comment 9

6 years ago
Created attachment 707992 [details] [review]
https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/118

Very straightforward patch.  I add a test sub-case that fails without the fix.  I also added a try block on the aggregating MessageFilterer that I verified logs a nice console.error message without the fix.
Attachment #707992 - Flags: review?(squibblyflabbetydoo)

Updated

6 years ago
Attachment #707992 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 10

6 years ago
landed on gaia-email-libs-and-more/master:
https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/118

landed on gaia/master:
https://github.com/mozilla-b2g/gaia/pull/7910
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

6 years ago
blocking=tef? request:

Bug 821447 improved our subject display logic for missing subjects, but either increased or introduced the problem where a message without a subject would break subject search.  That bug is present on v1.0.0.

We already have a fix that is now landed on master, and would like to land that.  If tef+ can't be granted, we would like leo+ or approval-v1.

Note that bug 835411 which is a dupe of this bug that I am going to dupe here is marked UX-P1, TEF_REQ, and PRODUCT-FIXFEATURE in the whiteboard.
blocking-b2g: --- → tef?
Depends on: 821447
(Assignee)

Updated

6 years ago
Duplicate of this bug: 835411
Breaking email search is pretty bad, since this is a straightforward fix we'll block and get uplift to mozilla-b2g18 tip as well as mozilla-b2g18_v1_0_0
blocking-b2g: tef? → tef+
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → affected
v1-train: 5f97bb66a70e0e61b1604f2572dc88cbbc140a10
v1.0.0: c4589884c89f724ba0f72107968d4111d4a9f1b2
status-b2g18: affected → fixed
status-b2g18-v1.0.0: affected → fixed

Comment 15

5 years ago
Build ID: 201302014070203
Kernel: Dec 5
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/d1288313218e
Gaia:   6544fdb8dddc56f1aefe94482402488c89eeec49

Verified on "Unagi"
This bug no longer reproduces.

Comment 16

5 years ago
Verified fixed on Unagi:
Unagi Build ID: 20130322070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/4931ec89ebbe
Gaia: 85fd164691bb852f1cfaf82405df4380629ced6e
Status: RESOLVED → VERIFIED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.