Crash trying to view contents of local directory file:///c|\

VERIFIED FIXED

Status

()

Core
Embedding: APIs
--
major
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: bmartin, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Latest mfcembed dated: 05-30-01

O/S: Win98
System: Dell Latitude CPi 400MHz 128MB RAM

Steps:
1. Download latest embed-win32.zip and extract file
2. Launch mfcembed.exe
3. Enter file:///c|/ in the URL text field to view contents of the directory

Results:
mfcembed caused invalid page fault in module xpcom.dll at 015f:60e9a870
select close
mfcembed caused invalid page fault in module mfc42.dll
(Assignee)

Comment 1

17 years ago
*** Bug 85969 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

17 years ago
Crash is occurring in nsStreamConverterService. Probably the converter that 
turns a directory listing into HTML/RDF is missing.

Checking further.
(Assignee)

Comment 3

17 years ago
Crash is triggered by missing http-index-format stream converter 
object implemented by mozilla/xpfe/components/directory and part of 
appcomps.dll. This causes a null pointer to be passed into a hash table lookup 
which then crashes.

Patch follows to insert pointer check. Getting directory viewer to actually 
work in embedding is more involved because of how the viewer is packaged and 
some issues with the chrome.
(Assignee)

Comment 4

17 years ago
Created attachment 39560 [details] [diff] [review]
Review please. 1 line patch to check for null pointer

Comment 5

17 years ago
r=rpotts

Comment 6

17 years ago
sr=darin (i think i filed a dupe of this a while back... probably assigned it to
valeski).  we'll hit this anytime someone asks for a stream converter that doesn't
exist.
(Assignee)

Comment 7

17 years ago
Fix is checked in (to trunk)
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
Clean up verification of dated code change bus
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.