Adjust landing page for reviewers

VERIFIED FIXED in 2013-01-31

Status

P3
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: clouserw, Assigned: chuck)

Tracking

2013-01-31
Points:
---

Details

(Whiteboard: u=rev p=1)

(Reporter)

Description

6 years ago
When reviewers hit the "Reviewer Tools" link they go to https://marketplace-dev.allizom.org/reviewers/ and then apparently click the "____ pending app reviews" link.  This bug is simply changing the "Reviewers Tool" link in the footer to point to https://marketplace-dev.allizom.org/reviewers/apps/queue/ instead.  Easy as pie.
Bug 769705 is to add the charts and info about the other queues on the reviewer tools "home page". If we automatically send them to the pending queue will they ever see this?
(Reporter)

Comment 2

6 years ago
(In reply to Rob Hudson [:robhudson] from comment #1)
> Bug 769705 is to add the charts and info about the other queues on the
> reviewer tools "home page". If we automatically send them to the pending
> queue will they ever see this?

Lisa and Andrew - is it worth adding charts to the home page now?
(In reply to Wil Clouser [:clouserw] from comment #2)
> (In reply to Rob Hudson [:robhudson] from comment #1)
> > Bug 769705 is to add the charts and info about the other queues on the
> > reviewer tools "home page". If we automatically send them to the pending
> > queue will they ever see this?
> 
> Lisa and Andrew - is it worth adding charts to the home page now?

I'll leave this to Lisa - I don't understand the logic behind bug 833081.
Flags: needinfo?(adora)
I agree with the request in Comment 1, to just change where the footer link goes.  Further ideas about what happens to the "____ pending reviews" chart added to Bug 833081, but I defer to Bram who's working on designs to clean up the review workflow as a whole.
Flags: needinfo?(adora)

Comment 5

6 years ago
Yep. Clicking on the “Reviewer Tools” link should bring users to the Queue page.

In addition to this, the Queue page should be a start page. And our current start page is actually a great candidate for the “Stats” or “Leaderboards” page.

Should I open a new bug for this?
(In reply to Bram Pitoyo [:bram] from comment #5)
> Yep. Clicking on the “Reviewer Tools” link should bring users to the Queue
> page.

What I was trying to point out was there's not a single queue page. There's 3 queue pages. 4 if you're a Senior Reviewer. And 5 if you count the moderated reviews as a queue page. It only looks like there's one queue page b/c of bug 769705 isn't implemented.

Here's a screenshot of what the intention is, which is a half-finished patch I have for that bug: http://cl.ly/image/063y1g151o1P

But if the pending review queue is where you want to be 99% of the time this makes sense to me.

Comment 7

6 years ago
Ah. (In reply to Rob Hudson [:robhudson] from comment #6)
> What I was trying to point out was there's not a single queue page. There's
> 3 queue pages. 4 if you're a Senior Reviewer. And 5 if you count the
> moderated reviews as a queue page. It only looks like there's one queue page
> b/c of bug 769705 isn't implemented.

Correct me if I’m wrong, but I believe that we’ve already solved this problem by making each sub-page into a tab?

For example, if I open the Queues page right now, I see four tabs:
* Apps (this should be renamed into “Pending review” so we’re not confused)
* Re-reviews
* Updates
* Moderated

If each tab has different “Current waiting time” tables, then we can give each its own table that’s relevant to that tab only.

I think the Pending Review Queue is where most users want to be most of the time. If it’s not, then the next tab is a click away.
(In reply to Bram Pitoyo [:bram] from comment #7)
> Correct me if I’m wrong, but I believe that we’ve already solved this
> problem by making each sub-page into a tab?

I wouldn't say 'solved' exactly - the 'tabs' are just links which load an entire new page, and they aren't visible on mobile view.

> For example, if I open the Queues page right now, I see four tabs:
> * Apps (this should be renamed into “Pending review” so we’re not confused)

All the queues contain pending reviews of some type or other so it wouldn't make it any less confusing.  (As an added confusion, on AMO the update queue is called pending.  I tend to try to refer to the 'Apps' queue as the submission queue)

> * Re-reviews
> * Updates
> * Moderated
> 
> If each tab has different “Current waiting time” tables, then we can give
> each its own table that’s relevant to that tab only.

Where would this table be?

> I think the Pending Review Queue is where most users want to be most of the
> time. If it’s not, then the next tab is a click away.

Probably a fair assumption at this point,
Should we also consider that theme reviews are coming here in the not too distant future? I've seen the code but not the front-end and can't recall if it'll be just 1 more queue or if it's a separate landing page for themes, e.g. /reviewers/apps/ is where we go now, but /reviewers/themes/ might be the new location? I could find out if it matters.

Then again, this bug is a "simple as pie" link change. That will be "simple as pie" if we ever want to change it back, as well.
(In reply to Rob Hudson [:robhudson] from comment #9)
> Should we also consider that theme reviews are coming here in the not too
> distant future? I've seen the code but not the front-end and can't recall if
> it'll be just 1 more queue or if it's a separate landing page for themes,
> e.g. /reviewers/apps/ is where we go now, but /reviewers/themes/ might be
> the new location? I could find out if it matters.

IIRC, the idea was that reviewer tools was a single place and depending on the group membership various queues would be visible to the reviewer.  So I think it was just one more queue - I'm not sure if that was designed, or just how it was easiest to implement at the time though.  How things will be handled when themes (and addons) come onto Marketplace should be considered definitely.
(Assignee)

Updated

6 years ago
Assignee: robhudson.mozbugs → charmston
(Assignee)

Comment 11

6 years ago
I'm took this ticket off Rob's hands, because I'm a nice guy like that.

Seems that there's a consensus that, in the short term, Wil's suggestion is a step toward better usability, so I went ahead and implemented that here:

https://github.com/mozilla/zamboni/commit/aa484a9e35dc60395a8c456a57472923c637afdc

As Rob mentioned, it's a simple link change that could easily be modified in the future.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 12

6 years ago
Verified as fixed in https://marketplace-dev.allizom.org/ on FF21 (Win 7).
Postfix screencast http://screencast.com/t/BbchPMYzxY
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.