About string policy and error

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
5 years ago
2 months ago

People

(Reporter: Leo, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title : About string policy
2. Precondition : 
3. Tester's Action : Setting - Display - Scree timeout - Select screen - "never". Other menu string also.
Cost control - Reset report - "Never"
Email - cc, bcc (not Cc/Bcc)
setting -Device information - (Software update) Check now - xxx.xx "kB" downloaed (not KB)

4. Detailed Symptom (ENG.) : Start letter of some string on menu is not Capital letter
6. Expected : 
7. Reproducibility: Y
1)Frequency Rate : 100%
8. Gaia revision : a03f7b532e9998e646d55f93a0fc03a04d7ca7d9
(Reporter)

Updated

5 years ago
Assignee: nobody → leo.bugzilla.gaia
(Reporter)

Comment 2

5 years ago
Created attachment 716833 [details]
link to path on github
Attachment #716833 - Flags: review?(timdream)
Attachment #716833 - Flags: review?(ehung)
(Reporter)

Comment 3

5 years ago
Created attachment 716834 [details]
link to path on github_modify

Modify github URL
Attachment #716834 - Flags: review?(timdream)
Attachment #716834 - Flags: review?(ehung)
Comment on attachment 716834 [details]
link to path on github_modify

Redirect to Pike for string change review.
Attachment #716834 - Flags: review?(timdream)
Attachment #716834 - Flags: review?(l10n)
Attachment #716834 - Flags: review?(ehung)
Comment on attachment 716833 [details]
link to path on github

dup or obsolete?
Attachment #716833 - Flags: review?(timdream)
Attachment #716833 - Flags: review?(ehung)

Comment 6

5 years ago
Comment on attachment 716834 [details]
link to path on github_modify

I don't think they're all correct, in particular the kB one is very likely wrong.

For those that are OK, you'll need to change the string key so that localizers pick up the requested change.
Attachment #716834 - Flags: review?(l10n) → review-
(Reporter)

Comment 7

5 years ago
Then, leo team can't change the string key becuase translation issue.

I don't really understand why add new srting key.
Never - The start letter must be capital
KB - other languages are all 'KB'


If you want to chage the string key, it will be fixed by Mozilla Gaia engineer.
(Reporter)

Comment 8

5 years ago
Another string issue,
Idle - Settings - Internet sharing -  Hotspot settings - Security
Please change from open to Open.

leo should be update english, spanish and portugese(Brasil)
(Reporter)

Updated

5 years ago
Assignee: leo.bugzilla.gaia → nobody
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?

Comment 9

5 years ago
We agreed that we would discuss this in a different setting (putting needinfo on Jaime/Axel to get their opinions), but since this isn't a regression from v1.0.1, we're not going to consider it a blocker.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Flags: needinfo?(l10n)
Flags: needinfo?(jachen)

Comment 10

5 years ago
I'd point to https://etherpad.mozilla.org/gaia-copy-guidelines, if we're looking for directions on casing and punctuation etc. Does that answer the question?
Flags: needinfo?(l10n)

Comment 11

5 years ago
That etherpad pad page does not cover dropdown or selector options.

I believe that the case of "Never" should be capitalized in the description and "Open" in comment 8.

In addition, I do believe it should be "KB" if we want to be consistent with what is shown in the email attachments UX spec.

I will ask Rob to update the etherpad to include both selection options and also file type abbreviations.

I do not think this should be blocking, but agree with tracking + nom.
Flags: needinfo?(jachen) → needinfo?(rmacdonald)
Thanks for highlighting this issue. I confirmed the style for the value selector (sentence case) and updated the spec at https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/UX/Style_guide#Copy_tone.
Flags: needinfo?(rmacdonald)

Comment 13

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.