Closed Bug 833626 Opened 12 years ago Closed 12 years ago

[traceback] mkt.developers.models._create_bango- SolitudeError: There was an error with that request.

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID
2013-02-14

People

(Reporter: krupa.mozbugs, Assigned: wraithan)

References

()

Details

(Whiteboard: p=)

steps to reproduce:
1. Submit a paid app
2. Click on "Set up Payments"
3. Select the default options for all payment settings and select a bango account
and save changes

sentry: http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/10904/

traceback details:

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "amo/decorators.py", line 160, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 152, in wrapper
    return f(*args, **kw)
  File "addons/decorators.py", line 33, in wrapper
    return f(request, addon, *args, **kw)
  File "amo/decorators.py", line 33, in wrapper
    return func(request, *args, **kw)
  File "mkt/developers/decorators.py", line 49, in wrapper
    return fun()
  File "mkt/developers/decorators.py", line 28, in <lambda>
    *args, **kw)
  File "mkt/developers/views_payments.py", line 76, in payments
    bango_account_list_form.save()
  File "mkt/developers/forms_payments.py", line 363, in save
    payment_account=self.cleaned_data['accounts'])
  File "mkt/developers/models.py", line 192, in create
    product_uri, addon, payment_account, secret)
  File "mkt/developers/models.py", line 229, in _create_bango
    'secret': secret
  File "lib/pay_server/base.py", line 173, in wrapped
    return self.call(url, method, data=data)
  File "lib/pay_server/base.py", line 138, in call
    code=code)


sentry: http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/10904/
Summary: [traceback]http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/10904/ → [traceback] mkt.developers.models._create_bango- SolitudeError: There was an error with that request.
I think this was a temporary issue with solitude config on -dev that stopped it working, can you retry please.
This is from the logs:

Jan 22 17:00:54 dev1: [] s.proxy:ERROR SSLError :/solitude/lib/proxy/views.py:58
Jan 22 17:00:54 dev2: [] requests.packages.urllib3.connectionpool:DEBUG "POST /proxy/bango HTTP/1.1" 500 None :/venv/lib/python2.6/site-packages/requests/packages/urllib3/connectionpool.py:283
Jan 22 17:00:54 dev2: [] django.request.tastypie:ERROR /bango/product/: AttributeError 'NoneType' object has no attribute 'responseCode'#012  File "/venv/lib/python2.6/site-packages/tastypie/resources.py", line 1165, in post_list#012#012  File "/solitude/lib/bango/resources/package.py", line 101, in obj_create#012    resp = get_client().CreateBangoNumber(form.bango_data)#012#012  File "/solitude/lib/bango/client.py", line 84, in call#012    self.is_error(response.responseCode, response.responseMessage)#012 :/solitude/solitude/base.py:210

Possible that Bango is having SSL issues?
This was only happening for a 30 minute period, whilst solitude was in an incomplete state due to a pip configuration error. I'm loathe to raise any issue with bango whilst our deployment was an incomplete state and might not have working certs for requests (I couldn't even load requests properly from a shell).
Wfm.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
This is happening again. See http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/10904/
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: p=
Taking this and putting on the current milestone.
Assignee: nobody → xwraithanx
Target Milestone: --- → 2013-02-14
Version: 1.0 → 1.1
What is the actual solitude error here? I'm pretty sure this was triggered by an old app. As of a couple days ago none of our existing apps will work. They all fail in 'invalid bango number' because Bango wiped their test db
Most recent event was `Private Yacht`, the other two events were `test app subdomain 13` and `payments testing`

I suspect the same and can't reproduce this.

Krupa can you reproduce this with an app that was submitted since the test DB wipe?
Flags: needinfo?(krupa.mozbugs)
Version: 1.1 → 1.2
We believe this was caused by old data or SSL errors.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → INVALID
Flags: needinfo?(krupa.mozbugs)
You need to log in before you can comment on or make changes to this bug.