Holdhome action does not cancel pending activity choices menu, covers everything except Cards View

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: alive, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #833454 +++

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/0e43266ca3c6
Gaia   1890022f3ca36108621a832f31ac5df8bf89a22e
BuildID 20130122070203
Version 18.0
Unagi

## Repro :
1. go to settings
2. press home
3. go to gallery
4. select a video
5. select share
6. long press home
7. choose settings app in cardview

## Expected :
1. goto settings app

## Actual :
1. settings app is below activity selector menu

## Solutions :
Short-term => cancel the activity on holding home button
Long-term => Make activity menu app-specific
Summary: When choosing activity, if you use cards view to switch to another app, the menu would still upon the new app → Holdhome action does not cancel pending activity choices menu, covers everything except Cards View
Created attachment 705205 [details]
https://github.com/mozilla-b2g/gaia/pull/7745

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #705205 - Flags: review?(timdream)
Attachment #705205 - Flags: approval-gaia-v1?(21)
Attachment #705205 - Flags: review?(timdream) → review+
blocking-b2g: tef? → -
https://github.com/mozilla-b2g/gaia/commit/9d73c9c61609489668f7f5ae2caeeb610bc35716
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 705205 [details]
https://github.com/mozilla-b2g/gaia/pull/7745

There's no apparent case here for needing to uplift, it's on master so will ship with v1.1.0.  Please renom if there's a reason this needs to go into 1.0.1
Attachment #705205 - Flags: approval-gaia-v1?(21) → approval-gaia-v1-
Tracking-b2g19=20+ so this gets uplifted to v1-train once v1.0.1 has branched.
tracking-b2g18: --- → 20+

Updated

5 years ago
tracking-b2g18: 20+ → +
Uplifted commit 9d73c9c61609489668f7f5ae2caeeb610bc35716 as:
v1-train: c0326b10e436689afb541684a63a8517efaced0d
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.