[Video] When the video is played to the end, it repeats a small clip

RESOLVED FIXED in 1.1 CS (11may)

Status

Firefox OS
Gaia::Video
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: atsai, Assigned: djf)

Tracking

unspecified
1.1 CS (11may)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(Whiteboard: [CR 480599])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I found there's a small phrase shown after the video is end.

Build Info:
gaia: 28944fcd761bf54a296d1da3f54f49cab87de00d
b2g18: 118277:e3803e97aeff

STR:
1. Launch Video app and play a video recording.

Expected Result:
*. While the video reaches the end, it stops.

Actual Result:
*. When the video reaches the end, it plays a clip of video which it played a couple seconds ago.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?

Updated

5 years ago
tracking-b2g18: --- → +
blocking-b2g: tef? → -

Comment 1

5 years ago
i can repro it too...

it looks like video skips back to the beginning before returning to the video playlist, also noticed that in the playlist the video is not displayed with the start up image

*Reproducible for both, recorded and transferred videos
*Same videos play well on PC

Unagi Build ID: 2013-02-07-070202
Gecko: cf1b9d27345e70daf242514733f848e76241ea1d
Gaia: 7e54ca673277b20b1d91d18477dc44d6ad226761

Updated

5 years ago
blocking-b2g: - → leo?
Whiteboard: [CR 480599]
(leo+ as this is now reported by our test folks)
Blocks: 856773
blocking-b2g: leo? → leo+
tracking-b2g18: + → ---
I thought it was just a quirky transition effect :P

As pointed out in comment one, this happens because when a video reaches the end the video app resets the timer back to zero. In fact, if you remove this line you won't see the skip:

https://mxr.mozilla.org/gaia/source/apps/video/js/video.js#943

But now the video won't rewind. And the reason there's a bit a playback after the rewind is because it generates a new frame for the thumbnail. Some options:

a. Figure out a way to generate the new thumbnail offscreen
b. Don't update the thumbnail on each playback?

Updated

5 years ago
Target Milestone: --- → 1.1 CS (11may)
(Assignee)

Comment 4

5 years ago
See also bug 859281. The fix for that one might fix this one too.

The thumbnail gets updated everytime playback stops because we want the user to see where they video will resume from.
Tried it out after the bug 859281 patch landed. No dice :(
(Assignee)

Comment 6

5 years ago
I think the right way to approach this might be to permanently store the initial poster image for the video, and only generate that during metadata parsing. Then, separately, we can generate another "bookmark" image for partially-played videos.  But if we don't overwrite the initial poster image, then we won't have to re-generate it when we reach the end of a video and we won't have this jank.

I've been working on the Video app a lot recently, so I'll grab this one.
Assignee: nobody → dflanagan
Sounds good to me
(Assignee)

Comment 8

5 years ago
Created attachment 747148 [details]
link to patch on github

Dale,

This patch changes the video app so it always holds on to the initial poster image for each video, and also saves a "bookmark" image when the video has been partially played and will resume somewhere other than the beginning.  It fixes the bug where the seeking to get the poster image was visible.

The video app has changed a bit since you last worked on it. For another unrelated bug I moved the metadata-related stuff to a separate file.  This bug looks like it makes big changes to captureFrame(), but most of the change is just a changed level of nesting: the frame capturing code itself is unchanged.
Attachment #747148 - Flags: review?(dale)
Comment on attachment 747148 [details]
link to patch on github

Looks great, merged in https://github.com/mozilla-b2g/gaia/commit/f73e380ec94496707180aa8c4be0e87fdf65d9d2
Attachment #747148 - Flags: review?(dale) → review+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
v1-train uplift please?
status-b2g18: --- → affected
(Assignee)

Comment 11

5 years ago
Uplifted to v1-train: https://github.com/mozilla-b2g/gaia/commit/16724dba558e7c6c6520281e30301fc388fa4c19
status-b2g18: affected → fixed

Updated

5 years ago
Flags: in-moztrap?

Comment 12

5 years ago
Added B2G Video Suite Test Case #8516 - [B2G Video] At the end of a video playback the user is returned to the File Browser video list without issue
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.