[SMS] The "Deselect All" button is transparent, and message list is visible through it when the message list is more than the list screen

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Leo, Assigned: Leo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: UX-P?)

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

6 years ago
1. Title : The "Deselect All" button is transparent, and message list is visible through it when the message list is more than the list screen
2. Precondition : Sms should be working and should contain the list of messages(the list screen should be more than 1.5 pages)
3. Tester's Action : Message - Edit Message - message list - Deselect all button
4. Detailed Symptom (ENG.) : The Deselect All button is transparent and message list is visible from it.
5. Expected : The Deselect All button should not be transparent.
6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Revision: 7b8dea7e7ec377a2143151bbe5e9998d87f7b36d"
(Assignee)

Comment 1

6 years ago
Pointer for pull request.
https://github.com/mozilla-b2g/gaia/pull/8116


Please review
(Assignee)

Updated

6 years ago
Assignee: nobody → leo.bugzilla.gaia
(Assignee)

Comment 2

6 years ago
Created attachment 716430 [details]
Pointer to pull request
Attachment #716430 - Flags: review?(fbsc)
I will take a look asap! Thanks for the patch!
Created attachment 716956 [details]
patch

Please Leo, review this patch. We changed "edit mode" building block for disabled buttons. To apply it correctly we should use disabled attribute instead of class disabled.
Attachment #716956 - Flags: review?
(Assignee)

Comment 5

6 years ago
Comment on attachment 716430 [details]
Pointer to pull request

><!DOCTYPE html><meta charset="utf-8"><meta http-equiv="refresh" content="5;https://github.com/mozilla-b2g/gaia/pull/8116"><title>Bugzilla Code Review</title><p>You can review this patch at <a href="https://github.com/mozilla-b2g/gaia/pull/8116">https://github.com/mozilla-b2g/gaia/pull/8116</a>, or wait 5 seconds to be redirected there automatically.</p>
(Assignee)

Comment 6

6 years ago
Comment on attachment 716430 [details]
Pointer to pull request

><!DOCTYPE html><meta charset="utf-8"><meta http-equiv="refresh" content="5;https://github.com/mozilla-b2g/gaia/pull/8116"><title>Bugzilla Code Review</title><p>You can review this patch at <a href="https://github.com/mozilla-b2g/gaia/pull/8116">https://github.com/mozilla-b2g/gaia/pull/8116</a>, or wait 5 seconds to be redirected there automatically.</p>
(Assignee)

Comment 7

6 years ago
Comment on attachment 716430 [details]
Pointer to pull request

><!DOCTYPE html><meta charset="utf-8"><meta http-equiv="refresh" content="5;https://github.com/mozilla-b2g/gaia/pull/8116"><title>Bugzilla Code Review</title><p>You can review this patch at <a href="https://github.com/mozilla-b2g/gaia/pull/8116">https://github.com/mozilla-b2g/gaia/pull/8116</a>, or wait 5 seconds to be redirected there automatically.</p>
(Assignee)

Comment 8

6 years ago
Comment on attachment 716430 [details]
Pointer to pull request

This is not the right pointer
Attachment #716430 - Flags: review?(fbsc)
(Assignee)

Comment 9

6 years ago
Hi Borja Salguero [:borjasalguero]

Sorry for the unwanted comments above.

As last item in the list displayed under "Deselect All" button,
We have made the last child of the list to one level up.

Please look at below
https://github.com/mozilla-b2g/gaia/pull/8116

Please review

Thanks.
Created attachment 722777 [details]
Patch
Attachment #716956 - Attachment is obsolete: true
Attachment #716956 - Flags: review?
Attachment #722777 - Flags: review?(fbsc)
(Assignee)

Updated

5 years ago
blocking-b2g: --- → leo?
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Whiteboard: UX-P?
Since it does not break functionality and is a polish issue, we will track.  The UX team will review the issue further.
Created attachment 736280 [details]
patch
Attachment #722777 - Attachment is obsolete: true
Attachment #722777 - Flags: review?(fbsc)
Attachment #736280 - Flags: review?(fbsc) → review+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 736280 [details]
patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Incorrect usage of disabled buttons
User impact if declined: incorrect visual component
Testing completed: yes
Risk to taking this patch (and alternatives if risky): very low. Replaced class="disabled" for disabled state, to apply styles as defined in Building Blocks 
String or UUID changes made by this patch:
Attachment #736280 - Flags: approval-gaia-v1?

Updated

5 years ago
Attachment #736280 - Flags: approval-gaia-v1? → approval-gaia-v1+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 6c095cb6ab33cac3deaf5c16a24519ba312dc4a7
  <RESOLVE MERGE CONFLICTS>
  git commit
Blocks: 861844
this broke the tests for Sms.

filed bug 861844.
Uplifted commit 6c095cb6ab33cac3deaf5c16a24519ba312dc4a7 as:
v1-train: a1059759c01e34cb9d921aad85adc01b307a4138
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.