[SMS] When taping to view a conversation of 100 messages, the app does nothing for 6sec before showing the conversation screen

VERIFIED FIXED

Status

Firefox OS
Gaia::SMS
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: etienne, Assigned: etienne)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ fixed, b2g18-v1.0.0 fixed)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Assignee)

Description

6 years ago
We know the current solution of fetching all the message from one contact at once doesn't scale well, and we have plans to resolve this (see bug 806592 dependencies).

But in the meantime we could at least give the user some visual cue that the conversation is loading, the current experience is borderline dogfood-blocker.
(Assignee)

Updated

6 years ago
blocking-b2g: --- → tef?
(Assignee)

Comment 1

6 years ago
Created attachment 705410 [details] [diff] [review]
Patch proposal

With this patch we animate the slide to the "conversation" panel as soon as a conversation is selected. Then load and render the messages as fast as possible.

We could easily add a spinner of some sort if it makes sense to the UX team.
Assignee: nobody → etienne
Attachment #705410 - Flags: review?(fbsc)
We would take a patch for this
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Created attachment 705780 [details]
Small fix to the patch for Keyboard
Hi Etienne! The code looks nice, but there is a weird behaviour in transition when keyboard is shown. I've uploaded a small patch to your patch fot fixing this issue. Please add this code and for me it's ok! Let me know when you have the final patch for reviewing.
Created attachment 705783 [details]
Right fix for keyboard issue
Created attachment 705787 [details]
Even better patch to Keyboard issue
Attachment #705780 - Attachment is obsolete: true
Attachment #705783 - Attachment is obsolete: true
Updated the patch properly.
Duplicate of this bug: 829519
blocking-b2g: - → tef?
This one should be tef+ due to the bug related with the 'loading-time' of a conversation it's fixed by the patch. However, https://bugzilla.mozilla.org/show_bug.cgi?id=827815 it's a 'optimization/polish', so that one should be nominated as 	tracking-b2g18+ (overall because that patch will be based on this one).
(Assignee)

Comment 11

6 years ago
Created attachment 705857 [details] [diff] [review]
Patch v2

Patch updated with the smooth transition back when the keyboard is displayed.
Attachment #705410 - Attachment is obsolete: true
Attachment #705787 - Attachment is obsolete: true
Attachment #705410 - Flags: review?(fbsc)
Attachment #705857 - Flags: review?(fbsc)
Attachment #705857 - Flags: review?(fbsc) → review+
blocking-b2g: tef? → tef+
(Assignee)

Comment 12

6 years ago
landed on master

https://github.com/mozilla-b2g/gaia/commit/0f2448ef3db1d9179be8fe12891c0abb487d4c52
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Created attachment 706270 [details]
sms gaia-ui-test script for 100 sms

I tested this in pvt b2g18 user build.

Gaia:
  Rev     7cacbcb8042b49d816a34de8e9767dcedefa6d84
  B-D     2013-01-25 02:57:10
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/32c2cc3e19ff
BuildID   20130124140859
Version   18.0

I tried to send 100 sms. However, it still took 4 sec for 100 2-line messages. I don't think it improve a lot.

attached the script of gaia-ui-test
(please change the number before you start it.)
I don't know if this is a valid fix. Leave this for other QAs to judge
(Assignee)

Comment 15

6 years ago
(In reply to Walter Chen from comment #14)
> I don't know if this is a valid fix. Leave this for other QAs to judge

The long term plan is not to load all the message of the conversation and have some sort of pagination.
Since this require a new UX, new visuals, and more dev it wasn't doable for this milestone.

This patch's goal is to start the transition between the thread list and the conversation right away to give the user visual feedback.

Feel free to update the summary, but the app now shows the conversation screen right away (and then loads the conversation).
OK.
Status: RESOLVED → VERIFIED
(In reply to Etienne Segonzac (:etienne) from comment #15)
> (In reply to Walter Chen from comment #14)
> > I don't know if this is a valid fix. Leave this for other QAs to judge
> 
> The long term plan is not to load all the message of the conversation and
> have some sort of pagination.
> Since this require a new UX, new visuals, and more dev it wasn't doable for
> this milestone.

Can you explain this in more detail?  Why is new UX, visuals, etc needed?

Short of that, why can't we just load messages into the UI in chunks to give better responsiveness?  That is, load most recent 10, repaint, (load other messages chunked).
(Assignee)

Comment 18

6 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #17)
> (In reply to Etienne Segonzac (:etienne) from comment #15)
> > (In reply to Walter Chen from comment #14)
> > > I don't know if this is a valid fix. Leave this for other QAs to judge
> > 
> > The long term plan is not to load all the message of the conversation and
> > have some sort of pagination.
> > Since this require a new UX, new visuals, and more dev it wasn't doable for
> > this milestone.
> 
> Can you explain this in more detail?  Why is new UX, visuals, etc needed?

Don't know the details, but I'm guessing a "load more" button if you scroll all the way up, or a "pull dowan to load more"...

> Short of that, why can't we just load messages into the UI in chunks to give
> better responsiveness?  That is, load most recent 10, repaint, (load other
> messages chunked).

This is a really good idea, I don't see why we can't :)
Filed bug 834895.
status-b2g18-v1.0.0: --- → fixed
You need to log in before you can comment on or make changes to this bug.