Closed Bug 833909 Opened 7 years ago Closed 4 years ago

Attachment reminder notification bar not instantly shown if using 'Edit as new' on saved mail/draft/template containing keyword

Categories

(Thunderbird :: Message Compose Window, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 48.0

People

(Reporter: aryx, Assigned: aceman)

References

Details

Attachments

(1 file)

3.81 KB, patch
jorgk
: review+
aceman
: feedback?
aryx
Details | Diff | Splinter Review
Windows XP SP3 32 bit, Thunderbird Daily 20130123 and 17.0.2. Also reported on Windows 7 Professional

The attachment reminder doesn't show up if the user edits a previously saved email hew was writing which contains at least one keyword which should launch the attachment reminder bar. Clicking into the recipient field and back into the message body shows the reminder.

Steps to reproduce:
1. Open a new compose window.
2. Add a recipient and a subject.
3. Add this as message body: This mail should have an attachment or else I have forgotten it.
4. Save the mail and close the compose window.
5. Go to the folder 'Drafts', right click the saved message and choose 'Edit As new'.

Actual result:
Attachment reminder shows up after 3., but not after 5.
If I understand :aryx correctly, this is only about showing the attachment reminder *notification bar* at the bottom of compose window.

I think this involves recycling of compose window, which is known to cause all sorts of problems with default setting of mail.compose.max_recycled_windows;1.

Using STR from comment 0 (tb17.0.8, winxp), this wfm if I only have a single draft open:
- closing single draft1 which has notification bar,
- then "edit as new" of same draft
-> instantly shows notification bar again.

However, with more than one draft it's different as reported here:
- just leave draft1 open,
- return to 3pane and "edit as new" again to create draft2 from same draft1
-> notification bar is not immediately seen, only reappears after clicking into content area;
-> when sending msg without seeing notification bar, attachmend reminder does not trigger (datalossy)

"Edit as new" would usually involve editing msg body which will always show the notification bar, so I think this bug as reported in comment 0 is minor. The worse part is this:
- explicitly click "Remind me later",
- then save, close and reopen draft in whichever mode (edit, edit as new),
-> you will NOT be reminded at all, which is datalossy at least for users who rely on the reminder alert. But I think we need a new bug for that.
Severity: normal → minor
Summary: Attachment reminder not shown if using 'Edit as new' on saved mail/draft/template containing keyword → Attachment reminder notification bar not shown if using 'Edit as new' on saved mail/draft/template containing keyword
Summary: Attachment reminder notification bar not shown if using 'Edit as new' on saved mail/draft/template containing keyword → Attachment reminder notification bar not instantly shown if using 'Edit as new' on saved mail/draft/template containing keyword (involves mail.compose.max_recycled_windows)
Blocks: 919286
Blocks: 926056
No longer blocks: 926056
I corroborate comment 2, with this addition.

if mail.compose.max_recycled_windows;0 (non-default setting) then no notification bar until I click in message body

Archaeopteryx, what is your setting?
Flags: needinfo?(archaeopteryx)
Daily 20140204, Windows 8.1 Pro 64 bit

With mail.compose.max_recycled_windows having the default value 1, the issue occurs if Thunderbird gets closed after saving the message and then relaunched and the message opened for editing.
Flags: needinfo?(archaeopteryx)
(In reply to Wayne Mery (:wsmwk) from comment #2)
> I corroborate comment 2, with this addition.
It's certainly good to corroborate your own comment within the very same comment ;p
So does this bug actually involve compose window recycling? I.e. does it NOT happen if mail.compose.max_recycled_windows=0? Or if TB is restarted before reopening the draft. It seems to me comment 2 and comment 3 disprove both cases.
In that case, the summary was incorrectly changed and needs to be rectified.

It appears to me it is a bug in launching the reminder regardless if recycling is done.
Assignee: nobody → acelists
Happens both with and without recycling compose windows (in latest Daily).
Summary: Attachment reminder notification bar not instantly shown if using 'Edit as new' on saved mail/draft/template containing keyword (involves mail.compose.max_recycled_windows) → Attachment reminder notification bar not instantly shown if using 'Edit as new' on saved mail/draft/template containing keyword
Attached patch patchSplinter Review
The keyword checker of the reminder only fired on mutations (changes/edits) of the message body (editor). When opening a draft the initializing the editor and populating of the body is done before starting the checker. We probably can't start the checker before that as it needs an initialized editor (to check the body contents). So, run the checker once on startup in case there is already some body populated. Then wait for next mutations.

Try run: https://hg.mozilla.org/try-comm-central/rev/55a1a8fb3941690044fc5303fa9ae2582950beed
Attachment #8736510 - Flags: review?(mozilla)
Attachment #8736510 - Flags: feedback?(aryx.bugmail)
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: x86 → All
Comment on attachment 8736510 [details] [diff] [review]
patch

Review of attachment 8736510 [details] [diff] [review]:
-----------------------------------------------------------------

This looks very good. I tested it using "Edit draft" and "Edit as new message" since this has changed since the bug was reported. I didn't run the test, I trust that you have.
Attachment #8736510 - Flags: review?(mozilla) → review+
The test has passed as can be seen in the try run I pasted.
Locally, the test does not pass without the fix (so the test should actually test something).
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/bfd81bd6163b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 48.0
You need to log in before you can comment on or make changes to this bug.