Library 'libulp.so' not found

RESOLVED DUPLICATE of bug 787838

Status

()

Core
Geolocation
RESOLVED DUPLICATE of bug 787838
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

18 Branch
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/32f66481e161
Gaia   None
BuildID 20130123070202
Version 18.0
Unagi
  
## Repro :
1. open camera for the first time
2. select allow for geolocation
3. look at logcat

## Expected :
no errors

## Actual :
error libulp.so not found

## Note :
Regression ( bug 787838 should have fixed this issue? )
This breaks geolocation I believe from reading the comments in that bug.
I'm not sure if we will block on broken geolocation...  Having said that... Geolocation is broken.

Logcat:
01-23 15:02:13.636: E/LocSvc_eng(109): I/===> int loc_eng_read_config() line 1909 
01-23 15:02:13.636: E/LocSvc_afw(109): E/const ulpInterface* loc_eng_get_ulp_inf(), dlopen for libulp.so failed, error = Cannot load library: load_library[1091]: Library 'libulp.so' not found
01-23 15:02:13.636: E/LocSvc_eng(109): I/===> int loc_eng_init(loc_eng_data_s_type&, LocCallbacks*, LOC_API_ADAPTER_EVENT_MASK_T, void (*)(void*, void*)) line 245 
01-23 15:02:13.636: E/LocSvc_eng(109): E/int loc_eng_init(loc_eng_data_s_type&, LocCallbacks*, LOC_API_ADAPTER_EVENT_MASK_T, void (*)(void*, void*)): log_eng state error: instance already initialized
Doug - Any ideas?

Is this a dupe of the "geolocation is broken on unagi" bug?
Flags: needinfo?(doug.turner)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787838

Updated

5 years ago
blocking-b2g: tef? → ---
tracking-b2g18: ? → ---
Flags: needinfo?(doug.turner)
You need to log in before you can comment on or make changes to this bug.