The default bug view has changed. See this FAQ.

at some scaling factors national character glyphs sizes/styles are mismatched

NEW
Unassigned

Status

()

Core
Internationalization
16 years ago
8 years ago

People

(Reporter: Robert Spalek, Unassigned)

Tracking

({intl})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Mozilla 0.9 2001050521
language-preferences: czech [cs], english [en]
codepage used: windows-1250

In all URL's (example given above) the default fonts look well.  But when I
scroll the font sizes by a mouse wheel, standard and national characters are
taken from another fonts sometimes -- sometimes one font is in italic and the
other is not, sometimes one font is bigger than another one.

I don't know how the font selection mechanism works, perhaps the missing fonts
is the problem, but perhaps there's an error.

I send a screenshot too (but it is not the worst one, I've seen much more ugly
pages).
(Reporter)

Comment 1

16 years ago
Created attachment 36583 [details]
screenshot of http://zive.cz/

Comment 2

16 years ago
-> i18n
Assignee: trudelle → nhotta
Status: UNCONFIRMED → NEW
Component: XP Toolkit/Widgets → Internationalization
Ever confirmed: true
QA Contact: aegis → andreasb

Comment 3

16 years ago
Reassign to bstell, cc to ftang.
Assignee: nhotta → bstell

Comment 4

16 years ago
Maybe we should put ISO-8859-2 into a seperate group than WESTERN in 
nsFontMetricsGTK.cpp
robert@ucw.cz- do you have a local build? can you try patch if I can send you 
one? I cannot reproduce your problem right now. 

mark moz0.9.3 
Assignee: bstell → ftang
Target Milestone: --- → mozilla0.9.3
(Reporter)

Comment 5

16 years ago
I have not built the sources, I just downloaded the nightly build, now it is the
version 2001060411, which has the error too.

If you tell me, how to download a local build and how to apply your patch, I
surely would try it.  But I'm afraid it would take too long time to compile
Mozilla on my K6-300.

Updated

16 years ago
Keywords: intl

Comment 6

16 years ago
I think the problem is we do not have language group for all in the 
nsFontMetricsGTK.cpp
 x-central-euro,  x-cyrillic, el, tr, he, ar, th,x-baltic
later to solve this
we should add
nsFontLangGroup FLG_CE =      { "x-central-euro", nsnull };
nsFontLangGroup FLG_CYRILLIC ={ "x-cyrillic", nsnull };
nsFontLangGroup FLG_BALTIC =  { "x-baltic", nsnull };
nsFontLangGroup FLG_EL =      { "el", nsnull };
nsFontLangGroup FLG_TR =      { "tr", nsnull };
nsFontLangGroup FLG_HE =      { "he", nsnull };
nsFontLangGroup FLG_AR =      { "ar", nsnull };
nsFontLangGroup FLG_TH =      { "th", nsnull };

and 
-   { "cp1251-1",           &FLG_NONE,    &CP1251        },
-   { "iso8859-13",         &FLG_WESTERN, &ISO885913     },
-   { "iso8859-2",          &FLG_WESTERN, &ISO88592      },
-   { "iso8859-4",          &FLG_WESTERN, &ISO88594      },
-   { "iso8859-5",          &FLG_NONE,    &ISO88595      },
-   { "iso8859-6",          &FLG_NONE,    &ISO88596      },
-   { "iso8859-7",          &FLG_WESTERN, &ISO88597      },
-   { "iso8859-8",          &FLG_NONE,    &ISO88598      },
-   { "iso8859-9",          &FLG_WESTERN, &ISO88599      },
-   { "koi8-r",             &FLG_NONE,    &KOI8R         },
-   { "koi8-u",             &FLG_NONE,    &KOI8U         },
-   { "tis620.2529-1",      &FLG_NONE,    &TIS620        },
-   { "tis620.2533-0",      &FLG_NONE,    &TIS620        },
-   { "tis620.2533-1",      &FLG_NONE,    &TIS620        },
-   { "tis620-0",           &FLG_NONE,    &TIS620        },
-   { "iso8859-11",         &FLG_NONE,    &TIS620        },

+   { "cp1251-1",           &FLG_CYRILLIC,&CP1251        },
+   { "iso8859-13",         &FLG_BALTIC,  &ISO885913     },
+   { "iso8859-2",          &FLG_CE,      &ISO88592      },
+   { "iso8859-4",          &FLG_BALTIC, &ISO88594      },

+   { "iso8859-5",          &FLG_CYRILLIC,&ISO88595      },
+   { "iso8859-6",          &FLG_AR,      &ISO88596      },
+   { "iso8859-7",          &FLG_EL,      &ISO88597      },
+   { "iso8859-8",          &FLG_HE,      &ISO88598      },
+   { "iso8859-9",          &FLG_TR,      &ISO88599      },
+   { "koi8-r",             &FLG_CYRILLIC,&KOI8R         },
+   { "koi8-u",             &FLG_CYRILLIC,&KOI8U         },
+   { "tis620.2529-1",      &FLG_TH,      &TIS620        },
+   { "tis620.2533-0",      &FLG_TH,      &TIS620        },
+   { "tis620.2533-1",      &FLG_TH,      &TIS620        },
+   { "tis620-0",           &FLG_TH,      &TIS620        },
+   { "iso8859-11",         &FLG_TH,      &TIS620        },


will this solve your problem ? If so, let's try to put into moz0.9.3 as nsBranch 
since it is low risk.
Whiteboard: nsBranch

Comment 7

16 years ago
reassign to bstell
Assignee: ftang → bstell

Comment 8

16 years ago
I will put a real patch later. 

Updated

16 years ago
QA Contact: andreasb → ylong

Comment 9

16 years ago
I think this is one of the low risk fix.
Keywords: nsBranch
Whiteboard: nsBranch

Comment 10

16 years ago
reassign to ftang
Assignee: bstell → ftang

Comment 11

16 years ago
Created attachment 40555 [details] [diff] [review]
patch to add addtional lang group

Comment 12

16 years ago
bstell- can you code review this one ?
robert- does this fix your problem ?

Comment 13

16 years ago
I'd like to study this a bit.

Robert: 
1) can you set the environment variable NS_FONT_DEBUG=9 and capture moz's
   output when displaying this page and attach it to this bug?

2) Can you also attach the output of "xlsfonts -u"?

3) What system are you running?

4) Does you system just have stock fonts or have you installed additional
   fonts?

Updated

16 years ago
Summary: national character are ugly in some font sizes → at some scaling factors national character glyphs sized/styles are mismatched

Updated

16 years ago
Summary: at some scaling factors national character glyphs sized/styles are mismatched → at some scaling factors national character glyphs sizes/styles are mismatched

Comment 14

16 years ago
This patch (attachment 40555 [details] [diff] [review]) is a fairly large change who's ramification are 
not well know to solve the problem:

  at some sized the glyphs do not all match

Comment 15

16 years ago
ok, definitely too risky for nsbranch. remove nsbranch.
I think we should try to land to trunk at least. bstell- can you r= this one and 
we get a sr= so we can land to the trunk?
Keywords: nsBranch

Comment 16

16 years ago
I would be more comfortable making this change if we saw the problem
in a more standard situation and/or other pages.

Comment 17

16 years ago
remove m9.3
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 18

16 years ago
move to bstell
Assignee: ftang → bstell

Updated

16 years ago
Status: NEW → ASSIGNED

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Reporter)

Comment 19

16 years ago
Sorry, I've been out for a long time.  I don't compile Mozilla, so I can not
apply source patches.  Now I use mozilla 0.9.3 build id 2001080104 and
everything seems OK on other pages (zive.cz is not available now).

I run Debian 3.0 woody system on i386 platform, XFree86 4.0.2, SawFish window
manages.

I've some additional iso-latin-2 fonts installed on the system.  I don't know
their original source, I got them from my friend :-)
(Reporter)

Comment 20

16 years ago
Created attachment 47162 [details]
gzipped listing of the fonts

Comment 21

16 years ago
Many factors control how the Linux/Unix Mozilla displays characters.

The CSS font name spec (if specified) tells the font subsystem which is the 
web page designer's desired font. If a font of this name is available it will 
be the first font in the list of fonts to get glyphs from. 

The user's font preference provides a fallback font name which the font 
subsystem uses if the CSS font name is not specified or is not available.
This font will be next in the list of fonts to get glyphs from. This setting
is per language group so depending on what encoding the browser thinks the
page is in the glyphs may be selected from a different font.

The CSS font size spec (if specified) tells the font subsystem which is the 
web page designer's desired font size. If the CSS font size is missing the
font size comes from the user's pref for the document's language group. When 
picking fonts the font subsystem will try to find a font a near to this size 
as possible.

If a font style of the exact style (regular vs bold, roman vs italic, etc)
is not available, the font subsystem will try to make the text readable
even if it means the style is not an exact match.

If there are characters that are not available in the first font the
browser still needs to display those characters so it will go looking for
other fonts to fill in from. The code first looks in fonts in the document's
language group. Next it looks in fonts in the user's locale's language 
group. Next it looks at all the fonts in user font preferences. Next it
looks in all fonts available. Next it tries to transliterate (eg: "(c)" for
the copyright symbol). The last choice is a question mark, '?', character.

I'm not surprised that at some sizes it showes that the font subsystem is 
doing this character fill-in.

If the system has a font of the desired name, of the desired size, of the 
desired style, and with the desired characters and the font subsystem is
filling in from other fonts this would be a bug.

Can we identify such a case?

Updated

16 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

16 years ago
Target Milestone: mozilla0.9.6 → Future

Comment 22

16 years ago
--> ftang
Assignee: bstell → ftang
Status: ASSIGNED → NEW

Comment 23

16 years ago
bulk move NEW FUTURE bug to ASSIGN
Status: NEW → ASSIGNED

Comment 24

12 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Comment 25

12 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 26

12 years ago
Mass Re-assinging Frank Tangs old bugs that he closed won't fix and had to be
re-open. Spam is his fault not my own
Assignee: ftang → nobody
Status: REOPENED → NEW
QA Contact: amyy → i18n
You need to log in before you can comment on or make changes to this bug.