Deleting files from the download manager does not remove the files from the device

VERIFIED FIXED in Firefox 20

Status

()

VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: wgianopoulos, Assigned: bnicholson)

Tracking

({regression})

20 Branch
Firefox 21
ARM
Android
regression
Points:
---
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(firefox19 unaffected, firefox20 verified, firefox21 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Using currently Nightly and Aurora builds, deleting files via the download manager just removes the download manager entry, but fails to actually delete the file.

This forks fine on the current Beta version.
(Reporter)

Updated

6 years ago
Summary: Deleting files form the download manager does not remove the files from the device → Deleting files from the download manager does not remove the files from the device
(Reporter)

Comment 1

6 years ago
(In reply to Bill Gianopoulos [:WG9s] from comment #0)
> Using currently Nightly and Aurora builds, deleting files via the download
> manager just removes the download manager entry, but fails to actually
> delete the file.
> 
> This forks fine on the current Beta version.
       ^^^^^
       works

Updated

6 years ago
status-firefox19: --- → unaffected
(Reporter)

Updated

6 years ago
Blocks: 820491
Assignee: nobody → bnicholson
Let's try to figure this out and get an uplift ready.

Updated

6 years ago
tracking-fennec: --- → ?
status-firefox20: --- → affected
status-firefox21: --- → affected

Updated

6 years ago
Flags: in-moztrap?(fennec)
There's a scoping  error with the logging that I saw yesterday (this.log is not defined) in removeDownload, but that will likely just show us whats being logged...
(Assignee)

Comment 5

6 years ago
From logcat (with bug 834400 fixed):

01-24 12:16:28.161 26435 26527 E GeckoConsole: Error: removeDownload() [Exception... "Not enough arguments [nsIFile.remove]"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: chrome://browser/content/aboutDownloads.js :: dl_removeDownload/< :: line 457"  data: no]
(Assignee)

Comment 6

6 years ago
Created attachment 706014 [details] [diff] [review]
Add required param for f.remove()
Attachment #706014 - Flags: review?(wjohnston)
Attachment #706014 - Flags: review?(wjohnston) → review+
(Assignee)

Comment 8

6 years ago
Comment on attachment 706014 [details] [diff] [review]
Add required param for f.remove()

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 820491
User impact if declined: files on phone aren't deleted when removed from download manager
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): very low risk
String or UUID changes made by this patch: none
Attachment #706014 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f07f88fd036a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21

Updated

6 years ago
status-firefox21: affected → fixed
Comment on attachment 706014 [details] [diff] [review]
Add required param for f.remove()

looks good, regression fix with low risk - approving.
Attachment #706014 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 12

6 years ago
Verified fixed on Samsung Galaxy SII  (Android 4.0.3)/ Nightly 21.0a1(2013-01-28) /Aurora 20.0a2(2013-01-28)
status-firefox20: fixed → verified
status-firefox21: fixed → verified

Updated

6 years ago
Status: RESOLVED → VERIFIED

Comment 13

6 years ago
There is already a TC in Moztrap for this: https://moztrap.mozilla.org/manage/case/831/

Should we adjust more this one? or it is OK with you too?
Flags: in-moztrap?(fennec) → in-moztrap+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.