If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[mortar] ensure both hosted and packaged use case works

RESOLVED FIXED

Status

Marketplace
Developer Pages
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: wenzel, Assigned: jlongster)

Tracking

Points:
---

Details

(Whiteboard: u=dev c=mortar p=2 s=2013.1)

(Reporter)

Description

5 years ago
At the recent apps events, some people tried pointing the Simulator to the mortar directory on the harddrive (rather than using ``volo serve``).

I believe this makes the Simulator treat it as a packaged app.

Instead of the app, they saw a directory listing, perhaps because the manifest launch path does not contain "/index.html".

Please ensure both use cases (hosted and packaged) work with the Simulator. Ideally, the very same manifest works for this. If not, what do you suggest?
(In reply to Fred Wenzel [:wenzel] from comment #0)
> Ideally, the very same manifest works for this. If not, what do you suggest?

I can share info about the mini-manifest and what we do on marketplace for packaged apps. Although I hear the Simulator is very close to being able to install packaged apps itself along with proper permissions for enabling access to sensitive APIs.

I *almost* had a python script to serve a directory that does request-time zipping of the package and serving the mini-manifest, but when testing it with FxOS it causes the server to throw a broken pipe error and I haven't dug into what's going on. But for reference, if it helps, it's here:
https://github.com/mozilla/zamboni/blob/master/scripts/serve_packaged_apps.py
(Assignee)

Comment 2

5 years ago
I'm pretty sure this was just a problem with the "launch_path" in the manifest.webapp, regardless of whether or not it's packaged. If you did "add directory" in the simulator instead of "add URL", you get the problem.

I've tweaked the "launch_path" variable to be "/index.html" which should work for both URLs and file://-based apps. I'm pretty sure that means it works as a packaged app as well. I'm marking this resolved unless someone can come up with a test case where this still doesn't work.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Blocks: 834582
You need to log in before you can comment on or make changes to this bug.