New DOM bindings static operations in workers

RESOLVED DUPLICATE of bug 816088

Status

()

RESOLVED DUPLICATE of bug 816088
6 years ago
6 years ago

People

(Reporter: janv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The generated code now uses |nsISupports* global| (instead of |JSObject* global|), so it tries to call |xpc_qsUnwrapArg<nsISupports>(cx, val, &global, &globalRef.ptr, &val)| which then fails.

A static method in the impl object currently looks like this:
IDBKeyRange*
IDBKeyRange::Only(JSContext* aCx, nsISupports* aGlobal, const JS::Value& aValue,
                  ErrorResult& aRv)

I think, |nsISupports* aGlobal| should be |JSObject* aGlobal| and the xpc_qaUnwrapArg() shouldn't be called at all.
(Reporter)

Updated

6 years ago
Blocks: 798875
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816088
You need to log in before you can comment on or make changes to this bug.