Update Fonts on B2G

RESOLVED FIXED in B2G C4 (2jan on)

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: padamczyk, Assigned: mwu)

Tracking

unspecified
B2G C4 (2jan on)
All
Other
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(Whiteboard: visual design UX-P3 yedo font)

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Hello, can we please remove:
- AndroidClock_Highlight.ttf   
- AndroidClock_Solid.ttf         
- AndroidClock.ttf               
- Clockopia.ttf 
- DroidSans-Bold.ttf
- DroidSans.ttf
- DroidSansMono.ttf
- DroidSerif-BoldItalic.ttf      
- DroidSerif-Bold.ttf            
- DroidSerif-Italic.ttf          
- DroidSerif-Regular.ttf
- Roboto-Bold.ttf
- Roboto-BoldItalic.ttf
- Roboto-Regular.ttf
- Roboto-Italic.ttf

Attached are higher quality / updated open source fonts.
1. Charis - Serif
2. Adobe Source Code - Monospaced
3. Roboto - Updated with all weights
4. Adobe Source Sans
(Reporter)

Comment 1

6 years ago
Created attachment 705851 [details]
Charis
(Reporter)

Comment 2

6 years ago
Created attachment 705852 [details]
Roboto (Updated)
(Reporter)

Comment 3

6 years ago
Created attachment 705853 [details]
Source Code Pro
(Reporter)

Comment 4

6 years ago
Created attachment 705854 [details]
Source Sans Pro
(Assignee)

Comment 5

6 years ago
A quick note - adding new fonts should be easy but removing them may be more difficult. The default android fonts are a bit more deeply embedded into the Android build system and we also make assumptions about Droid Sans being around. IIRC, Droid Sans is also the default Sans font so we would have to pick another default font if we want to eliminate Droid Sans.

I don't know how difficult updating roboto will be - I'll check.
(Reporter)

Comment 6

6 years ago
We may want to do this in a few rounds (bugs)
Lets remove the Droid Serif, and specify Charis as the default serif.
Roboto can just be copied over with the newer versions.
Adobe Source Code Pro should be the default monospaced.

And we're working with the type designer to expand the character set of MozTT (which will likely be renamed to Feura Sans), and that will be our default typeface for everything. I am hoping we can get this done v.1.1.
(Assignee)

Comment 7

6 years ago
Ok I have a plan for this. This bug will be for putting the fonts in the build and there will be another bug for changing the font defaults.

Patryk, can you link where you got these fonts from? Just the fonts isn't enough - we need licensing info and it would be easiest if you pointed out where these fonts came from and what version you want to use.
Flags: needinfo?(padamczyk)
(Assignee)

Comment 9

6 years ago
https://github.com/mozilla-b2g/moztt/commit/62f94a26d34c1f1e1846efd58d34363c051e8c66

This commit adds the fonts, but does not install them or remove any fonts. A commit to platform_build will be necessary to do that.

For reference, this is what the /system/fonts directory looks like after this is enabled:

root@android:/system/fonts # ls
CharisSIL-B.ttf
CharisSIL-BI.ttf
CharisSIL-I.ttf
CharisSIL-R.ttf
DroidNaskh-Regular.ttf
DroidSans-Bold.ttf
DroidSans.ttf
DroidSansArmenian.ttf
DroidSansEthiopic-Regular.ttf
DroidSansFallback.ttf
DroidSansGeorgian.ttf
DroidSansHebrew-Bold.ttf
DroidSansHebrew-Regular.ttf
DroidSansThai.ttf
MozTT-Bold.ttf
MozTT-Light.ttf
MozTT-Medium.ttf
MozTT-Regular.ttf
Roboto-Black.ttf
Roboto-BlackItalic.ttf
Roboto-Bold.ttf
Roboto-BoldCondensed.ttf
Roboto-BoldCondensedItalic.ttf
Roboto-BoldItalic.ttf
Roboto-Condensed.ttf
Roboto-CondensedItalic.ttf
Roboto-Italic.ttf
Roboto-Light.ttf
Roboto-LightItalic.ttf
Roboto-Medium.ttf
Roboto-MediumItalic.ttf
Roboto-Regular.ttf
Roboto-Thin.ttf
Roboto-ThinItalic.ttf
SourceCodePro-Black.ttf
SourceCodePro-Bold.ttf
SourceCodePro-ExtraLight.ttf
SourceCodePro-Light.ttf
SourceCodePro-Medium.ttf
SourceCodePro-Regular.ttf
SourceCodePro-Semibold.ttf
SourceSansPro-Black.ttf
SourceSansPro-BlackIt.ttf
SourceSansPro-Bold.ttf
SourceSansPro-BoldIt.ttf
SourceSansPro-ExtraLight.ttf
SourceSansPro-ExtraLightIt.ttf
SourceSansPro-It.ttf
SourceSansPro-Light.ttf
SourceSansPro-LightIt.ttf
SourceSansPro-Regular.ttf
SourceSansPro-Semibold.ttf
SourceSansPro-SemiboldIt.ttf

Note that DroidSans.ttf and DroidSans-Bold.ttf are just symlinks to Roboto.
(Assignee)

Updated

6 years ago
blocking-b2g: --- → leo?
(Assignee)

Comment 10

6 years ago
Pull request to flip the switch at https://github.com/mozilla-b2g/platform_build/pull/18

I also requested leo? so we can land this for 1.1.
(Assignee)

Updated

6 years ago
Blocks: 840315
blocking-b2g: leo? → leo+
does this fix bug 825091?
(Assignee)

Comment 12

6 years ago
Apparently this wasn't in v1-train, so I uplifted it to v1-train on moztt:

https://github.com/mozilla-b2g/moztt/commit/2c7ca7d1095a68d36de504df382a5ed4104bc84d
(Assignee)

Updated

6 years ago
Blocks: 849384
(Assignee)

Comment 13

6 years ago
The platform_build changes have also landed. Closing, but we'll need snapshot updates (bug 849384).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

6 years ago
Had to land a followup to switch to charis sil compact.
Can we set status-b2g18:fixed on this, Michael?
(In reply to Ryan VanderMeulen [:RyanVM] from comment #15)
> Can we set status-b2g18:fixed on this, Michael?

While everything is landed, the snapshots that we use haven't been deployed to our infrastructure.  I'm not sure how we should be marking this bug.
Mark it as depending on whatever snapshot update bug gets filed and set the status flags when it lands?
I believe that this is fixed on b2g18 now. Can someone confirm?
https://hg.mozilla.org/releases/mozilla-b2g18/rev/a827df06cffb
status-b2g18: --- → fixed
Target Milestone: --- → B2G C4 (2jan on)

Comment 19

6 years ago
Hi Michael,

I found this following commit already phase in master branch, shall it also needed for v1-train?
https://github.com/mozilla-b2g/platform_build/commit/c647d5f967a5f17aaa27c792ea0ee35a2d44b113

Comment 20

6 years ago
Hi Michael,

in v1-train branch, we found Chinese character can not shown in some none-qcom devices.
I think it comes from the missing of /system/fonts/DroidSansFallback.ttf, shall we also need to phase in following commit for v1-train branch?
https://github.com/mozilla-b2g/platform_build/commit/c647d5f967a5f17aaa27c792ea0ee35a2d44b113
Flags: needinfo?(mwu)
(Assignee)

Comment 21

6 years ago
We're going to try to update the fonts again. We don't need to uplift that backout to v1-train since we want the new font set.
Flags: needinfo?(mwu)
(Assignee)

Comment 22

6 years ago
https://github.com/mozilla-b2g/moztt/commit/3769dfb6566897c8dca0abdc596728602d5fabae puts Droid Sans Fallback back in. This was accidentally removed. Thanks for pointing that out.
(In reply to Michael Wu [:mwu] from comment #22)
> https://github.com/mozilla-b2g/moztt/commit/
> 3769dfb6566897c8dca0abdc596728602d5fabae puts Droid Sans Fallback back in.
> This was accidentally removed. Thanks for pointing that out.

Should we uplift this to v1-train?
Flags: needinfo?(mwu)
(Assignee)

Comment 24

6 years ago
There's a number of things that have to be uplifted involving fonts. I want to uplift all the font bits once we have them all landed and verified working.
Flags: needinfo?(mwu)

Updated

6 years ago
Blocks: 854771
Duplicate of this bug: 861068
(Assignee)

Comment 27

6 years ago
https://github.com/mozilla-b2g/platform_build/commit/7e18fb88e4579d8d1784f434a07ffe223f4b12db

All necessary pieces for this bug should be uplifted now. There's a lot of different pieces though - hopefully didn't miss anything.

Updated

5 years ago
Flags: in-moztrap-

Updated

5 years ago
Blocks: 964712
You need to log in before you can comment on or make changes to this bug.