If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsIWebBrowserPersist - saving a .txt file will save in html

RESOLVED INVALID

Status

()

Core
Document Navigation
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Arcterex, Assigned: Adam Lock)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This bug cropped up in galeon.  Full text from the original bug at 
http://bugzilla.gnome.org/show_bug.cgi?id=55459 below:

------------------
Basically what happens is that galeon will save a .txt file with html/pre
wrappers, even if it is not an html file with that code in it.  It looks
like it's using the internal renderer structure and dumping it to file,
instead of using the original (??).

To reproduce:
Go to the URL http://www.muppetlabs.com/~breadbox/software/tiny/hello.asm.txt
File->save as
Edit the file and notice the top line containing <html><head>, etc.
Repeat with the latest mozilla nightly and notice that it saves text properly.

Definately mozilla has the desired results, as people such as myself are
downloading non-html files off the net and having those files contents
change is a bad thing.

Netscape 4.x deals with this by having a "save as type" dropdown that has
the following choices for this file: source/text/postscript, and translates
the source to whatever format the user chooses on the way to the disk.

---------

Marco said it was a mozilla bug and that "we are using nsIWebBrowserPersist"

Comment 1

17 years ago
which mozilla version are you using (ie which one galeon embedds)? Not seeing
this on windows, will try linux later.
(Reporter)

Comment 2

17 years ago
I'm using the patched .9 debs available at
ftp://ufies.org/pub/galeon/people/christophe

Comment 3

17 years ago
embedding?
Assignee: asa → adamlock
Component: Browser-General → Embedding: Docshell
QA Contact: doronr → adamlock
(Assignee)

Comment 4

17 years ago
What method are you using to save the document with? If saveDocument then try 
saveURI.
(Reporter)

Comment 5

17 years ago
This looks like it was a problem in galeon, we now use SaveURI and it works as
expected, marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.