Cannot install free app with in-app payments

VERIFIED FIXED in 2013-01-31

Status

Marketplace
Payments/Refunds
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: kumar, Assigned: andym)

Tracking

2013-01-31
x86
Mac OS X
Points:
---

Details

Attachments

(1 attachment)

Created attachment 705953 [details]
$0.00 install button

STR:
- Submit an app like the in-app tester (http://inapp-pay-test.farmdev.com/manifest.webapp)
- Mark it as paid
- After submission, set up payments
- Set it to $0.00 and check the box for in-app payments
- Mark it as public
- View the listing and try to install it

Expected: the app should install immediately since it is free

Actual: the app says $0.00 and it makes you enter the pay flow (see screenshot)
Blocks: 775802
Priority: -- → P1
Assignee: nobody → thepotch
Target Milestone: --- → 2013-01-31
Duplicate of this bug: 834834
(Assignee)

Comment 2

5 years ago
I think I know what this is and might be able to do it. Would you mind if I took potch?
(Assignee)

Updated

5 years ago
Assignee: thepotch → amckay
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/zamboni/commit/bf999a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 4

5 years ago
Able to install free app with in-app purchases.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.