[Browser] Truncated Bookmark Label

VERIFIED FIXED

Status

Firefox OS
Gaia::Browser
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: patryk, Assigned: ivanovpavel)

Tracking

unspecified

Firefox Tracking Flags

(b2g18+ fixed)

Details

(Whiteboard: visual design, UX-P2, yedo, uxbranch, landed in uxbranch)

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 706049 [details]
Truncated Label drives me INSANE!

Pavel can you please fix this truncation? Ideally we wouldn't have to shrink the text string.
Try.
a) letter spacing
b) try a smaller font, weight 400, but not nothing smaller than 12px.

Spend me some screens before you make the patch. Thanks!
Created attachment 706576 [details]
examples

I hope this variants are enough :) What do you think?
Flags: needinfo?(padamczyk)
(Reporter)

Comment 2

5 years ago
Thanks for these, but Pavel, the fix would insure that "Bookma..." is not truncated. The label should be always read "Bookmarks" in english.
Flags: needinfo?(padamczyk)
Oh ... sorry I was thinking for the url's ... not for the title "Bookma..." ... I will give you new shots
Created attachment 706598 [details]
examples - v2

What about this one?
Flags: needinfo?(padamczyk)
Attachment #706598 - Attachment description: examples → examples - v2
(Reporter)

Comment 5

5 years ago
I'd go with the 1.3rem. I see you're using simulator. Just make sure it renders correctly on device as well. Thanks!
Flags: needinfo?(padamczyk)
Created attachment 706640 [details]
example - v3

device screenshot with :
font-size: 1.3rem;letter-spacing: -0.02rem;
Flags: needinfo?(padamczyk)
(Reporter)

Comment 7

5 years ago
ship it :)
Flags: needinfo?(padamczyk)
Attachment #706576 - Attachment is obsolete: true
Attachment #706598 - Attachment is obsolete: true
Created attachment 706791 [details]
patch for UX branch
Attachment #706791 - Flags: review?(sjochimek)

Comment 9

5 years ago
Comment on attachment 706791 [details]
patch for UX branch

landed in uxbranch: https://github.com/gordonbrander/gaia/commit/c1981f5af9707cf1c62066144ef94d8b939dd8f0
Attachment #706791 - Flags: review?(sjochimek) → review+

Updated

5 years ago
Whiteboard: visual design, UX-P2, szabla → visual design, UX-P2, szabla, uxbranch, landed in uxbranch

Updated

5 years ago
blocking-b2g: --- → shira?

Updated

5 years ago
blocking-b2g: shira? → leo?
Whiteboard: visual design, UX-P2, szabla, uxbranch, landed in uxbranch → visual design, UX-P2, yedo, uxbranch, landed in uxbranch

Updated

5 years ago
blocking-b2g: leo? → ---
(Reporter)

Updated

5 years ago
tracking-b2g18: --- → ?
Mass edit to set tracking-b2g18+ for these UX bugs that were called out for v1.1
tracking-b2g18: ? → +

Comment 11

5 years ago
https://github.com/mozilla-b2g/gaia/commit/25d9e53380db967d76223c5f1e1940ed907ed447
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
verified on master, not on v1 train
Master build : 2013-03-26-07-02-04
"mozilla-central" revision="28b048ffb7a7"
"integration/gaia-central" revision="44f6a17f24d4"
"gecko.git"revision="a800f14ea7022a78966f7fe14a9b0d11c569b151"
"gaia.git" revision="ace1eb32a313da1232bbdf9cff2581a4b036356d"
Status: RESOLVED → VERIFIED
status-b2g18: --- → verified
status-b2g18: verified → affected

Comment 13

5 years ago
Comment on attachment 706791 [details]
patch for UX branch

What is the status on this? Are we done-done and ready to go.

Comment 14

5 years ago
Comment on attachment 706791 [details]
patch for UX branch

Master commit hash is 63149e6

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: -
Testing completed: Yes see #c12
Risk to taking this patch (and alternatives if risky): no risk
String or UUID changes made by this patch: -
Attachment #706791 - Flags: approval-gaia-v1?(21)
Comment on attachment 706791 [details]
patch for UX branch

This comes from the UX branch process where QA has already checked that it works. a=me.
Attachment #706791 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x  63149e661d59b024aceb245d9085cfb29be2a42f
  <RESOLVE MERGE CONFLICTS>
  git commit
Sam? can you help with this one?
Flags: needinfo?(sjochimek)

Comment 18

5 years ago
This seems to conflict with https://bugzilla.mozilla.org/show_bug.cgi?id=830644 (https://github.com/mozilla-b2g/gaia/commit/e0d4130a). Is that (Bug 830644) bug going to be uplifted as well ?
Flags: needinfo?(sjochimek) → needinfo?(21)

Comment 19

5 years ago
What can we do to resolve this one?
(In reply to Stephany Wilkes from comment #19)
> What can we do to resolve this one?

Our choices are:

1) undo v1-train approval for this bug
2) approve v1-train for bug 830644
3) if it's a semantic-only merge conflict, the conflict can be resolved
(In reply to Sam Joch [:samjoch] from comment #18)
> This seems to conflict with
> https://bugzilla.mozilla.org/show_bug.cgi?id=830644
> (https://github.com/mozilla-b2g/gaia/commit/e0d4130a). Is that (Bug 830644)
> bug going to be uplifted as well ?

Welcome to the uplifting nightmare. This patch is probably way lighter than approving the whole set of patches of the responsive bug. So let's land this one first.
Flags: needinfo?(21)

Comment 22

5 years ago
I like that idea, Vivien. Let's do that. And John and Vivien, thanks for the release/uplift onboarding too. ;)
We can't do more here without conflicts resolved. Please supply a patch or uplift directly.
Flags: needinfo?(pivanov)
Flags: needinfo?(sjochimek)

Comment 24

5 years ago
uplifted in v1-train: https://github.com/mozilla-b2g/gaia/commit/c9046a7acef33328977840176ff5574720d2c74c
status-b2g18: affected → fixed
Flags: needinfo?(sjochimek)
Flags: needinfo?(pivanov)
You need to log in before you can comment on or make changes to this bug.