If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

review flag for "Firefox for Metro" should not have firefox-reviewers@mozilla.org as a watcher

RESOLVED DUPLICATE of bug 1022707

Status

()

bugzilla.mozilla.org
Administration
RESOLVED DUPLICATE of bug 1022707
5 years ago
3 years ago

People

(Reporter: Gavin, Unassigned)

Tracking

Production

Details

The firefox-reviewers mailing list was added as a watcher for the review flag of the "Firefox" product in bug 680122. The goal is to monitor review traffic for Firefox desktop.

I just noticed mail was sent from bug 831934 to the list, which shouldn't have been sent since it isn't in the "Firefox" component. I assume that what happened was that when the "Firefox for Metro" product was created in bug 797934, the "Firefox" review flag was used rather than the generic "review" flag.

Can we fix that please?
Not an easy task as the way flags work in Bugzilla makes this difficult to do once a flag has been used by all the products the flag has been enabled for. Currently there are 63 bugs with the review flag set for Metro.  Attributes such as the default cc, group permissions, etc. are based on the flag and not per product.

One way to do this we would need to create yet another review flag which has only the 'Firefox for Metro' product enabled for it and does not have the cc address in question. Then have IT run a SQL script that will update the type_id in the flags table for Metro bugs to the new type_id. And then on the old review flag with the cc address in question, remove the Metro product from the inclusion list.

Otherwise if we just simple do it from the admin UI, Bugzilla will happily drop those flags that are currently set on the Metro product causing data loss.

Byron, do you have any other suggestion than the above?

dkl
sorry, this request got lost in the machine.
duplicating to a more recent bug which has slightly more discussion.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022707
You need to log in before you can comment on or make changes to this bug.