Cannot dismiss recurring calandar entries that are synced with Google Calendar

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
6 years ago
2 years ago

People

(Reporter: simtre, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

(1) set up a sync between thunderbird calendar and google calendar using standard thunderbird feature.
(2) receive an email in my gmail account for a recurring event
(3) accept the event in the google calendar
(4) thunderbird calendar syncs with google calendar, and instances of the recurring event are visible.



Actual results:

(5) when an instance of the event becomes current, thunderbird provides a pop-up asking me to dismiss or snooze.
(6) Clicking either does nothing, and the popup returns.
(7) The only way of killing the popup is to go into Google calendar and delete that instance of the event.


Expected results:

When I click Dismiss, it should close the popup and dismiss the event.
When I click Snooze, it should snooze and close the popup.
NOTE: Everything works OK if it is not a recurring meeting.
What version of Thunderbird and Lightning do you use? Do you get any error messages in Tools > Error Console? How do you access Google Calendar? Using the CalDAV protocol or using the Provider for Google Calendar extension?
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 17 → unspecified
(Reporter)

Comment 2

6 years ago
Thunderbird v17.02
Lightning v1.9
There is no error or message of any kind in the error console.
I use CalDAV to sync. (If you want the CalDAV settings, please advise how because I cannot see a way of viewing the current CalDAV settings)

I noticed today that when I 'Dismiss' the meeting, the count of meetings at the top goes to zero but then is updated to one very quickly.

Comment 4

3 years ago
I get the same issue. I'm also getting an error about savings back to the event with changes? either way the result is the same and I'm stuck in a constant loop.
This bug is fairly old. I am trying to do some cleanup in this component. Please check out bug 1314185 and see if the dependencies of that bug cover your case should this still be an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.