Distorted PDF rendering.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: de.techno, Unassigned)

Tracking

17 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 706398 [details]
Buggy rendering.

Here, the rendered PDF is distorted, in a sense that some letters are small, while others are normal, and some are missing.

Attaching screenshot.

Zooming in/out fixes the problem for the current and a few pages below it, but will come back after you return to that part of the document.
(Reporter)

Comment 1

6 years ago
Created attachment 706399 [details]
Fixed rendering after zoom in/out
(Reporter)

Comment 2

6 years ago
I tried also with a new profile with hardware acceleration off.
Is there a file available to test or maybe a portion of the pdf?
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]
Flags: needinfo?(de.techno)
This PDF? (But I was unable to reproduce th problem.)
http://www.math.northwestern.edu/~mlerma/courses/cs310-05s/notes/dm-fsmach
Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130205 Firefox/21.0
Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0 beta 5

Could not reproduce on Ubuntu 12.10 x64 with latest Nightly and Beta builds. This issue seems to be fixed.
Setting WFM. Please reopen if the issue reappears.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(de.techno)
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

6 years ago
Yes, problem appears to be fixed in FF 19.

Although this gives problems -- 

http://www.inkwelleditorial.com/pdfSample.pdf

But this warrants a new bug.
You need to log in before you can comment on or make changes to this bug.