Closed Bug 834755 Opened 8 years ago Closed 8 years ago

SMSes sent without intl dialing prefix and country code are dropped

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 839094
blocking-b2g -
Tracking Status
b2g18 --- affected
b2g18-v1.0.0 --- affected
b2g18-v1.0.1 --- affected

People

(Reporter: overholt, Assigned: gwagner)

References

Details

Attachments

(1 file, 1 obsolete file)

1. Open SMS app
2. Press the pencil icon to start a new SMS app
3. Enter 10 digit phone # of my other phone (without the country code)
4. Enter a message
5. Press Send

Expected:
Message received on my other phone

Actual:
Message is not received

I'm fully willing to admin that I'm just Doing It Wrong here :)
blocking-b2g: --- → tef?
It turns out one needs the dialing prefix *and* country code.
Summary: Can't send SMS to number not in contact list → Sending SMS requires intl dialing prefix and country code
I think this is likely a dupe of bug 828861.
I think the actual results are worse than "Message is not received". When I click Send, the phone number and message are cleared and I am left in the compose window without any explanation of what has happened.
Whiteboard: DUPEME
(In reply to Andrew Overholt [:overholt] from comment #0)
> 1. Open SMS app
> 2. Press the pencil icon to start a new SMS app
> 3. Enter 10 digit phone # of my other phone (without the country code)

Can you give me a similar number to try?
Are you currently roaming?
(In reply to Gregor Wagner [:gwagner] from comment #4)
> (In reply to Andrew Overholt [:overholt] from comment #0)
> > 1. Open SMS app
> > 2. Press the pencil icon to start a new SMS app
> > 3. Enter 10 digit phone # of my other phone (without the country code)
> 
> Can you give me a similar number to try?

I'll email you

> Are you currently roaming?

No
Was it sent successfully? If not, this bug seems to duplicate bug 828861.
It was sent successfully when I used +1 (my country code) but not when I omitted +1.
Nice! Then this duplicates.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 828861
Clearing the nom as bug 828861 is the culprit here.
blocking-b2g: tef? → ---
Bug 828861 is fixed yet I am still not able to send SMSes to a number without the international prefix and the country code.  I am on a build that says:

2013-01-31 04:57:21
7a393bb76

but I don't know how that SHA-1 corresponds to the repos to verify that the fix for bug 828861 is there so I'm un-duping since I *think* it's there.
Status: RESOLVED → REOPENED
blocking-b2g: --- → tef?
Resolution: DUPLICATE → ---
(In reply to Andrew Overholt [:overholt] from comment #10)
> Bug 828861 is fixed yet I am still not able to send SMSes to
> a number without the international prefix and the country
> code.

I've told you in bug 828861 comments #63, "Actually this patch has nothing to do with the bug description." and you just don't listen.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #11)
> (In reply to Andrew Overholt [:overholt] from comment #10)
> > Bug 828861 is fixed yet I am still not able to send SMSes to
> > a number without the international prefix and the country
> > code.
> 
> I've told you in bug 828861 comments #63, "Actually this patch has nothing
> to do with the bug description." and you just don't listen.

Okay, so what's the best way forward in your opinion.  In my experience a lot of people do not store their contacts' numbers fully internationalized.
Flags: needinfo?(vyang)
Assignee: nobody → vyang
blocking-b2g: tef? → tef+
I've said several times, WONTFIX.  Please don't assign such bug to me again.
Assignee: vyang → nobody
Flags: needinfo?(vyang)
Let me clarify my STR:

Using a Canadian SIM (CityFone, a Rogers subsidiary/reseller) in Canada, sending an SMS to another Canadian phone number (regardless of their carrier)

> 1. Open SMS app
> 2. Press the pencil icon to start a new SMS app
> 3. Enter 10 digit phone # of my other phone (without the country code)
> 4. Enter a message
> 5. Press Send
> 
> Expected:
> Message received on my other phone
> 
> Actual:
> Message is not received

This works as expected ^ on all Android and Symbian phones that I've used.  I am not able to verify this behaviour with my CityFone SIM on an Android device without roaming right now.
When I first saw this bug, this was the situation:

MO = Unagi with Cityfone SIM (647xxxxxxx number)
MT_1 = Android with Fido SIM (416xxxxxxx number)
MT_2 = Unagi with Cityfone SIM (647xxxxxxx number)
I was in Canada, MO and MT_2 were on the Cityfone network, not roaming.  MT_1 was on the Fido network , not roaming.  Cityfone and Rogers are both using Rogers' network.

And this is what happened:

MO sends SMS to MT_1:  failure as above
MO sends SMS to MT_2:  failure as above

MO sends SMS to MT_1 with "+1" prefixed to phone number:  works (no failure as above)
MO sends SMS to MT_2 with "+1" prefixed to phone number:  works (no failure as above)
Using a '3' (UK carrier) SIM, I can successfully send an SMS from my Unagi to another UK number (Android device, not sure of the carrier) *without* prefixing with +44.

Using an O2 SIM, I can successfully send an SMS from my Unagi to another Unagi *without* prefixing with +44.  Both devices were on the O2 network at the time.

In these cases, the conversation view seems to automatically prefix the numbers I entered with "+44".
(In reply to Andrew Overholt [:overholt] from comment #15)
> When I first saw this bug, this was the situation:
> 
> MO = Unagi with Cityfone SIM (647xxxxxxx number)
> MT_1 = Android with Fido SIM (416xxxxxxx number)
> MT_2 = Unagi with Cityfone SIM (647xxxxxxx number)
> I was in Canada, MO and MT_2 were on the Cityfone network, not roaming. 
> MT_1 was on the Fido network , not roaming.  Cityfone and Rogers are both
> using Rogers' network.
> 
> And this is what happened:
> 
> MO sends SMS to MT_1:  failure as above
> MO sends SMS to MT_2:  failure as above
> 
> MO sends SMS to MT_1 with "+1" prefixed to phone number:  works (no failure
> as above)
> MO sends SMS to MT_2 with "+1" prefixed to phone number:  works (no failure
> as above)
Thanks for this information. One more question, which image version did you use?
(In reply to Andrew Overholt [:overholt] from comment #16)
> Using a '3' (UK carrier) SIM, I can successfully send an SMS from my Unagi
> to another UK number (Android device, not sure of the carrier) *without*
> prefixing with +44.
> 
> Using an O2 SIM, I can successfully send an SMS from my Unagi to another
> Unagi *without* prefixing with +44.  Both devices were on the O2 network at
> the time.
> 
> In these cases, the conversation view seems to automatically prefix the
> numbers I entered with "+44".
Thanks for this information. One more question, 
Doing this test in UK, which number do you send SMS to?
I've updated the summary to align more closely with the real problem here:  we are dropping the user into a blank SMS compose window if the SMS doesn't contain a fully-internationalized # and that is required for successful sending.

I'm not sure we can block on this since I imagine it doesn't happen on launch partner networks but I'd love to see us fix this.  I'll leave the blocking question open to the triage group.
Summary: Sending SMS requires intl dialing prefix and country code → SMSes sent without intl dialing prefix and country code are dropped
(In reply to Ken Chang from comment #17)
> (In reply to Andrew Overholt [:overholt] from comment #15)
> > When I first saw this bug, this was the situation:
> > 
> > MO = Unagi with Cityfone SIM (647xxxxxxx number)
> > MT_1 = Android with Fido SIM (416xxxxxxx number)
> > MT_2 = Unagi with Cityfone SIM (647xxxxxxx number)
> > I was in Canada, MO and MT_2 were on the Cityfone network, not roaming. 
> > MT_1 was on the Fido network , not roaming.  Cityfone and Rogers are both
> > using Rogers' network.
> > 
> > And this is what happened:
> > 
> > MO sends SMS to MT_1:  failure as above
> > MO sends SMS to MT_2:  failure as above
> > 
> > MO sends SMS to MT_1 with "+1" prefixed to phone number:  works (no failure
> > as above)
> > MO sends SMS to MT_2 with "+1" prefixed to phone number:  works (no failure
> > as above)
> Thanks for this information. One more question, which image version did you
> use?

At the time of initial filing it was probably the 2013-01-24 nightly build (received via OTA update).

> (In reply to Andrew Overholt [:overholt] from comment #16)
> > Using a '3' (UK carrier) SIM, I can successfully send an SMS from my Unagi
> > to another UK number (Android device, not sure of the carrier) *without*
> > prefixing with +44.
> > 
> > Using an O2 SIM, I can successfully send an SMS from my Unagi to another
> > Unagi *without* prefixing with +44.  Both devices were on the O2 network at
> > the time.
> > 
> > In these cases, the conversation view seems to automatically prefix the
> > numbers I entered with "+44".
> Thanks for this information. One more question, 
> Doing this test in UK, which number do you send SMS to?

Oops, sorry, I meant to specify that I sent it to another phone with an O2 SIM in it and both phones were on the O2 network at the time.

I am presently on a 2013-02-02 (da39f0b896) build.
Hi Andrew. I think that the problem it's the same as https://bugzilla.mozilla.org/show_bug.cgi?id=833291 . Could you take a look? Thanks!
(In reply to Andrew Overholt [:overholt] from comment #19)

Could you provide logcat with RIL debug message for this issue? Thank you!

You can turn on RIL debug message by:

adb remount
adb pull /system/b2g/defaults/pref/user.js user.js
[update user.js with adding 'pref("ril.debugging.enabled", true);']
adb push user.js /system/b2g/defaults/pref/user.js
adb shell reboot

You may also have to enable "Remote debugging" (under Settings->Device Information->More Information->Developer).
(In reply to Andrew Overholt [:overholt] from comment #19)
> > > Using an O2 SIM, I can successfully send an SMS from my Unagi to another
> > > Unagi *without* prefixing with +44.  Both devices were on the O2 network at
> > > the time.
> > > 
> > > In these cases, the conversation view seems to automatically prefix the
> > > numbers I entered with "+44".
> > Thanks for this information. One more question, 
> > Doing this test in UK, which number do you send SMS to?
> 
> Oops, sorry, I meant to specify that I sent it to another phone with an O2
> SIM in it and both phones were on the O2 network at the time.
> 
> I am presently on a 2013-02-02 (da39f0b896) build.

So this issue is only happened in Cityfone SIM?
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #21)
> (In reply to Andrew Overholt [:overholt] from comment #19)
> 
> Could you provide logcat with RIL debug message for this issue? Thank you!

Not until I'm back in Toronto on February 12th, sorry.
(In reply to Borja Salguero [:borjasalguero] from comment #20)
> Hi Andrew. I think that the problem it's the same as
> https://bugzilla.mozilla.org/show_bug.cgi?id=833291

I read that bug to be about not merging internationalized and non-internationalized numbers in the SMS conversation view.  This bug is about me not being able to send SMS messages to non-internationalized numbers at all.  So I don't think they're dupes.

(In reply to Vicamo Yang [:vicamo][:vyang] from comment #21)
> Could you provide logcat with RIL debug message for this issue? Thank you!
> 
> You can turn on RIL debug message by:

FWIW I've asked some other Mozillians who have Cityfone SIMs to try to get this information.
I tried to reproduce this on my unagi with a Cityfone SIM while in Mountain View. In this case, without prepending the +1 to the phone number the text message is correctly sent and received by my second (Android) phone. Given that I can reproduce the issue that Andrew first reported while in Toronto but cannot reproduce with the same phone and SIM in Mountain View I expect that this issue is specific to the Cityfone network.
Correct component.
Assignee: nobody → vyang
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
QA Contact: mbarone976
Assignee: vyang → chulee
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Assign to chuck.
(In reply to Andrew Overholt [:overholt] from comment #24)
> (In reply to Borja Salguero [:borjasalguero] from comment #20)
> > Hi Andrew. I think that the problem it's the same as
> > https://bugzilla.mozilla.org/show_bug.cgi?id=833291
> 
> I read that bug to be about not merging internationalized and
> non-internationalized numbers in the SMS conversation view.  This bug is
> about me not being able to send SMS messages to non-internationalized
> numbers at all.  So I don't think they're dupes.
> 
> (In reply to Vicamo Yang [:vicamo][:vyang] from comment #21)
> > Could you provide logcat with RIL debug message for this issue? Thank you!
> > 
> > You can turn on RIL debug message by:
> 
> FWIW I've asked some other Mozillians who have Cityfone SIMs to try to get
> this information.
Have you found someone to reproduce this test in Toronto?
Joe Drew and Mike Conley are Torontonians who could potentially help with reproducing.
Flags: needinfo?(mconley)
Attached file mconley's log (obsolete) —
I followed the STR in comment 0, and got the expected results (text was received on second phone, albeit after 3 minutes).

The number I entered was in the form of 647xxxxxxx.

The phone I received the message on is on the WindMobile network.

The unagi I'm using has the following information:

OS version: 1.0.0.0-prerelease
Build Identifier: 20130130070201
Git commit info hash: f7f5a0cd ...

I hope I delivered what it is you were asking for. Please let me know if there's anything else you need from me.
Flags: needinfo?(mconley)
Thanks, Mike.  When you're home tonight can you try it again on Cityfone so we can narrow down the potential for a carrier issue?
Flags: needinfo?(mconley)
Just so we're clear - the phone I sent the SMS from was on Cityfone. I was able to borrow a device (my dogfood phone is stuck at home today).
Flags: needinfo?(mconley)
(In reply to Mike Conley (:mconley) from comment #32)
> Just so we're clear - the phone I sent the SMS from was on Cityfone. I was
> able to borrow a device (my dogfood phone is stuck at home today).

Hi Mike,
   Can you please use the same image with the one of Andrew used before to do this test again? We have to double check if this is a carrier issue. Thanks.
We got iccinfo: {"mcc":302,"mnc":720} and operatorinfo {"mcc":302,"mnc":720}, so that's not roaming. Besides, SMS sending request got replied in line 3919, which is a success. Can't really find any errors yet :(
The log seems correct to me, if you can reproduce the bug, please provide log of both sender and receiver side.
Attached file mconley's log
Ok, I seem to have been able to reproduce this using the following build:

Build ID: 20130202230201
Git commit hash: 00c03496...

With Remote Debugging and RIL debugging enabled, I:

1) Booted the phone
2) Accidentally went into contacts, and then opened the SMS app.
3) Composed a new text message using a number in the form of 647xxxxxxx
4) Wrote the message "Hello", and pressed Send.

What happened?

Immediately after pressing send, the "Message" input was cleared and blurred, and the keyboard went away. No message appeared in the screen - it continued to read "No results returned."

Log is attached. Let me know if you need anything further.
Attachment #710816 - Attachment is obsolete: true
Depends on: 839094
Gregor emailed me about this.  If it does turn out to be specific to certain Canadian carriers, I don't think we can block on it (but obviously from a selfish point of view I'd like to see it fixed ;) ).
The patch in bug 839094 should fix it.
Assignee: chulee → anygregor
Status: REOPENED → RESOLVED
blocking-b2g: tef+ → -
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839094
Batch edit: Bugs still affected on b2g18 after 2/13 merge to v1.0.1 branch are affected on v1.0.1 branch.
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.