display the contacts that have been invited in a Facebook chat (social API)

RESOLVED WONTFIX

Status

()

Firefox
SocialAPI: Providers
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Florent Fayolle, Unassigned)

Tracking

19 Branch
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [platform-rel-Facebook])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130116072953

Steps to reproduce:

display the contacts that have been invited in a chat (social API)


Actual results:

The title of the chat is cropped when having several contacts, without tooltip. So I don't know the contacts who have been invited.


Expected results:

A solution could be to add an tooltip to display when hovering the title, with the same content than the latter but not cropped.

Note: I don't know if it is related to Firefox or to Facebook.
Component: Untriaged → SocialAPI
When looking at this, I can't reproduce the described problem exactly.  I just created a chat with 3 people, and the titlebar changed to "FirstName1, FirstName2 and FirstName3" - nothing cropped.  Then I tried again with 6 people, and got "FirstName1 and 5 others" - still nothing cropped.

That last case is still somewhat problematic - it's still impossible (AFAICT) to see who the "5 others" are.  So while it is easy for us to add a tooltip to the chat, it will still only display exactly what the title for the chat says - ie, in my examples above, it wouldn't actually add any value.

What we could do is add support so the providers can supply *different* text for the tooltip than for the label.  This would allow the providers to display the full names - but obviously the providers would need to change to leverage this.

Doing this would need an API change, so flagging it as such.  Also adding Shane for his thoughts.
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: [needs-api-change]
IMO it can be handled in content for now, keep what we do in chrome minimal.
iow, a tooltip will get cut off at some point as well, requiring us to do further work around how participants should be shown.  Keeping this in content keeps our end simple, allows a provider freedom to deal with it how they like.
(Reporter)

Comment 4

5 years ago
Created attachment 714400 [details]
screenshot of the actual contact list

> Then I tried again with 6 people, and got "FirstName1 and 5 others" - still nothing cropped.

Maybe that is because it is translated in French in my case. See the attached screenshot (note that contacts' information is hidden).

Florent
(Reporter)

Comment 5

5 years ago
Created attachment 714409 [details]
Proposal for this issue

> Keeping this in content keeps our end simple, allows a provider freedom to deal with it how they like.

I have another idea. 
I don't know whether it is you or the provider which handles the rendering of the contacts list, but you'll find attached a mockup. 
In that mockup (sorry, it is pretty ugly!), there is a "[...]" text which is actually clickable (like a simple link). On click, that button disappears, and the contacts list is expanded in a multiline display.

What do you think?

Florent
(In reply to fayolle-florent from comment #5)
> I have another idea. 
> I don't know whether it is you or the provider which handles the rendering
> of the contacts list, but you'll find attached a mockup. 

The provider just provides us with the title string.  If elipses are shown, then I expect the provider will be just including them in the string.  If that is the case, then we don't know what the full string should be.

IIUC, Shane's suggestion is that the provider still just provides a string for the title, but if necessary, display further UI directly in the content area.  Thus would put full control over this back into the hands of the providers (but as such, also means we can't do much on our end).
I think we are leaning towards making it the responsibility of the provider to display this in the content area when necessary.
Status: UNCONFIRMED → NEW
Component: SocialAPI → SocialAPI: Providers
Ever confirmed: true
Whiteboard: [needs-api-change]
Whiteboard: [platform-rel-Facebook]

Updated

2 years ago
platform-rel: --- → ?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.