Don't show add to existing contact UI if there are no contacts

RESOLVED DUPLICATE of bug 1041624

Status

RESOLVED DUPLICATE of bug 1041624
6 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({unagi})

unspecified
ARM
Gonk (Firefox OS)
unagi

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected, b2g-v1.3 affected, b2g-v1.3T affected, b2g-v2.1 affected)

Details

(Whiteboard: interaction, [UX-P2], TEF_REQ, permafail)

Attachments

(1 attachment)

Created attachment 706502 [details]
Screenshot of issue

unagi, seen while running

Gecko: 94a2d6fcdfde
Gaia: c814c79378b9

STR:
1. Without any contacts added, go into the Call log
2. Select one of the numbers in the log
3. Select add to Existing contact
4. Receive the attached screenshot

This UI isn't very useful since the + button is missing, but we probably shouldn't show that option if there are no contacts added.

Comment 1

6 years ago
> This UI isn't very useful since the + button is missing, but we probably
> shouldn't show that option if there are no contacts added.

the + button is present on Build ID: 20130130103345. Clicking it leads to an empty 'Add Contact' form which is not very helpful for the end user. However the user should not be able to progress this far in the first place. 

UX should be:

**PATH**
1) Ensure contact list is empty, 
2) navigate to the Call log with content (received, made or miss calls)
3) Select one of the numbers in the call log
4) observe the list of options presented

**CORRECT UX**
list of options should be:

- Call
- Create new contact
- Cancel

'Add to existing contact' should not be present if the contact list is empty as there are no contacts to add the phone number to.

[UX-P2]
Whiteboard: interaction, [UX-P2], TEF_REQ
I am able to reproduce this issue on Buri version 1.3 per a failed test case for Buri Run 1.3-1

https://moztrap.mozilla.org/manage/case/8467/

Add to existing contact displays even if contact list is empty with no contacts to add the phone number to. 

These are my Environmental Variables:

Device: buri 1.3 MOZ
BuildID: 20131216004002
Gaia: 1752e9e8f2b84b9db5d96ae5940596957fc8ed6c
Gecko: 2ec5a40f544e
Version: 28.0a2
RIL Version: 01.02.00.019.102
Whiteboard: interaction, [UX-P2], TEF_REQ → interaction, [UX-P2], TEF_REQ, burirun1.3-1
I was able to reproduce this issue on Buri version 1.2. 

Below are my Environmental Variables:

Device: buri 1.2 MOZ
BuildID: 20131217004001
Gaia: 4f53ba8b3628ac311253fc28dfdf66e7ba6832de
Gecko: 129ad3c335a5
Version: 26.0
RIL Version: 01.02.00.019.102
I was able to reproduce this issue on Buri version 1.1

Below are my Environmental Variables:

Device: buri 1.1 MOZ
BuildID: 20131217041201
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: bdac595a4e46
Version: 18.0
RIL Version: 01.02.00.019.102
status-b2g18: --- → affected
status-b2g-v1.2: --- → affected
status-b2g-v1.3: --- → affected
status-b2g-v1.3T: --- → affected
Whiteboard: interaction, [UX-P2], TEF_REQ, burirun1.3-1 → interaction, [UX-P2], TEF_REQ, burirun1.3-1, 1.3tarakorun2
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(dharris)
Whiteboard: interaction, [UX-P2], TEF_REQ, burirun1.3-1, 1.3tarakorun2 → interaction, [UX-P2], TEF_REQ, permafail
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 5

4 years ago
Hi, 
I would like to work on this bug,
Please assign the bug to me,
Thanks.
(In reply to Anusha from comment #5)
> Hi, 
> I would like to work on this bug,
> Please assign the bug to me,
> Thanks.

Hi Anusha,

just realised about this bug, this has been fixed in the new 2.1 version:
https://bugzilla.mozilla.org/show_bug.cgi?id=1041624

Thanks for the interest.

You can take a look to other bugs to be mentored at:
http://www.joshmatthews.net/bugsahoy/?b2g=1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041624
You need to log in before you can comment on or make changes to this bug.