Strange conflict of position: fixed & backface-visibility: hidden.

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jason, Unassigned)

Tracking

18 Branch
x86_64
Windows 8
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

See the demo at: http://jsfiddle.net/MKMUg/show/  (code: http://jsfiddle.net/MKMUg/)

=== demo code inlined below ======

html
{
    height: 100%;
    overflow: hidden;
}

body
{
    height: 100%;
    backface-visibility: hidden;
    overflow: hidden;
}

<div style="position: fixed; top: 0; left: 0; right: 0; bottom: 0; background: #CC33CC;"></div>


Actual results:

`<div style="position: fixed; top: 0; left: 0; right: 0; bottom: 0; background: #CC33CC;"></div>` does not cover fully unless in fullscreen mode.

Gap seems to grow or shrink with the size of the window-chrome.  Try Fullscreen mode to get full coverage.  Or try without bookmarks bar to get /some/ extra coverage! 


Expected results:

Magenta div should completely cover the document viewport.  

Changing either to `position: absolute` or removing `backface-visibility: hidden` will correct it, but of course, we shouldn't have to.
Looks likely to be a duplicate of bug 827577 at first glance...
Depends on: 827577

Comment 2

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #1)
> Looks likely to be a duplicate of bug 827577 at first glance...

Yes, regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f7c89de3ab43&tochange=3f0587ce1774
It's a regression in bug 788044 that's going to be patched in bug 827577.

But the testcase is crashy in FF21, I filed bug 833856.

Comment 3

6 years ago
Sorry, I filed bug 835056.
> Magenta div should completely cover the document viewport.  

Works for me in the latest Nightly 21.0a1 (2013-01-28) on Linux.
I think bug 830192 fixed this.
Flags: in-testsuite?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.